Bug 21810 - Method not implemented System.Web.HttpApplication.RegisterModule
Summary: Method not implemented System.Web.HttpApplication.RegisterModule
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-05 05:43 UTC by Mikhail Filippov
Modified: 2015-09-08 23:57 UTC (History)
21 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Demo application. (4.47 MB, application/zip)
2014-08-13 02:14 UTC, Mikhail Filippov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikhail Filippov 2014-08-05 05:43:30 UTC
I'm try run ASP .NET Application on Mono 3.6.0, i'm get error:
Application Exception
System.MissingMethodException
Method not found: 'System.Web.HttpApplication.RegisterModule'.

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00054] in /Volumes/build-root-ramdisk/mono-3.6.0/mcs/class/corlib/System.Reflection/MonoMethod.cs:230 
Version Information: 3.6.0 ((no/f540f8a Tue Jul 15 19:37:27 EDT 2014);
ASP.NET Version: 4.0.30319.17020
Comment 1 Mikhail Filippov 2014-08-05 07:05:28 UTC
I run Owin application. Over Owin.Hosting.SystemWeb
Comment 2 Rodrigo Kumpera 2014-08-12 20:07:59 UTC
Hi Mikhail,

Could you provide a sample of what you're trying to do that's not working? Your description is to broad to be actionable by us.

A test case and reproduction steps would greatly help us get it fixed.
Comment 3 Mikhail Filippov 2014-08-13 02:14:44 UTC
Created attachment 7671 [details]
Demo application.
Comment 4 Mikhail Filippov 2014-09-08 08:40:07 UTC
I add info.
Comment 5 Prez Cannady 2014-10-25 21:40:37 UTC
Same error examining the ASP.NET Identity Samples on Mono 3.x.



Sample project here:

https://github.com/revprez/revprez-bug-mono-20141025-aspnet-registermodule


System.MissingMethodException
Method not found: 'System.Web.HttpApplication.RegisterModule'.

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00054] in /private/tmp/source-mono-mac-3.10.0-branch/bockbuild-mono-3.10.0-branch/profiles/mono-mac-xamarin/build-root/mono-3.10.0/mcs/class/corlib/System.Reflection/MonoMethod.cs:230
Comment 6 Jeff Maher 2014-10-26 10:19:17 UTC
Also experiencing this issue. Here's the current revision I'm at with my project:

https://github.com/codeforamerica/golden-ticket/tree/d74b1b76b7358a4b448c0ae8a41cad4bf7847f1f
Comment 7 Jeff Maher 2014-10-26 10:22:12 UTC
Some additional information for my comment:

- Project initially created in Visual Studio 2013
- Error occurs using Xamarin Studio (fresh install on 10/26) on Mac OS X 10.8
Comment 8 Cheng 2014-12-26 13:50:29 UTC
I'm using asp.net identity 2.0 and got this error also.
and in my asp.net web api 2.2 project, I see System.Web.Entity dll is missing, it's wierd since on stackerflow, people are saying if I'm building MVC4 application using MONO 3.x, this dll will be bundled in.
Comment 9 Gardel Souza 2014-12-30 10:36:06 UTC
I'm facing the same issue after add SignalR package, is there any other alternative to build real-time app with asp.net mvc?
Comment 10 Dan Jarvis 2015-01-23 14:54:04 UTC
I am also interested in a resolution.  Does OWIN use the async pipeline which would require a *LOT* more work on Mono than just fulfilling the RegisterModule() call?

I am wanting to use SignalR and am wondering if I need to resort to using a non-OWIN version of this (v1.x).
Comment 11 Stefan Fischer 2015-01-25 11:42:47 UTC
Bugs me, too. AFAIK, OWIN doesn't require async controller actions, though ASP.NET Identity exposes some interfaces with async signature (which should not be a problem). Seems like the missing RegisterModule() method is the key.
Comment 12 Yan 2015-02-11 14:14:52 UTC
Experience the same issue with OWIN web app.
Comment 13 Blake Niemyjski 2015-03-20 18:46:09 UTC
I'm also seeing this exact same error when I try to run our project: https://github.com/exceptionless/Exceptionless
Comment 14 Steelrain89 2015-04-08 08:29:31 UTC
Has anyone found a solution yet?
Comment 15 Casey Gregoire 2015-05-04 03:26:49 UTC
T
Comment 16 Venson 2015-05-05 09:50:25 UTC
Still waiting for a Sollution. This bug prevents me from using the Default template for MVC
Comment 17 brian leung 2015-05-26 04:16:26 UTC
No luck even in using SignalR 1.2.2.  Still got the same error "HttpApplication.RegisterModule not found".  I think it is because the package Microsoft.AspNet.SignalR 1.2.2 also uses Microsoft.Owin.Host.SystemWeb.  

Any Solution Yet please?
Comment 18 Andres G. Aragoneses 2015-06-09 10:03:09 UTC
This has been fixed in mono master ( https://github.com/mono/mono/commit/58e0608c10c621b15fd9f396f8e46c567891b231 ), please mark the bug as RESOLVED->FIXED.
Comment 19 xameeramir 2015-07-16 03:30:46 UTC
So to get this fix, we need to compile from Git?
Comment 21 Mikhail Filippov 2015-09-01 16:00:40 UTC
Fixed in 4.2.0.
Comment 22 brian leung 2015-09-08 05:00:07 UTC
I just tried the mono 4.2.0 and it can run the Default MVC Template in Visual Studio 2013 (with authentication).  However, there is still error when I try to use SignalR 2.2 with mono 4.2.0.  Details:

https://github.com/luckyus/mono420_signalR2.git

Thank you.
Comment 23 Mikhail Filippov 2015-09-08 05:32:20 UTC
@brian I think this is not depend with this bug. May be you will open other bug.
Comment 24 delirium 2015-09-08 06:13:40 UTC
@brian the fact that you're seeing this in the console and not in the web browser means that it definitely gets into all the owin stuff. I had one of these too, related to my inability of copying some dlls and it took me days to figure this out because we only get the exception in a stage of the pipeline where it is too late to send it as a browser exception request (that's why it's printed to the command line).

I'd suggest trying to figure out the codepath that is actually failing, however prepare to invest a few days figuring this out.
Comment 25 Rodrigo Kumpera 2015-09-08 12:15:02 UTC
@brian could you file another bug report for your issue?
Comment 26 brian leung 2015-09-08 23:57:04 UTC
done

https://bugzilla.xamarin.com/show_bug.cgi?id=33809