Bug 20564 - SqlBulkCopy ordinal mappings do not work
Summary: SqlBulkCopy ordinal mappings do not work
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Data (show other bugs)
Version: master
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-12 17:45 UTC by Andrew Knowles
Modified: 2018-02-22 22:36 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andrew Knowles 2014-06-12 17:45:06 UTC
There are some issues with ordinal mappings.

Looks like source and destination are backwards in BulkCopyToServer.

Not to mention that neither is really correct there, since:
1) The source DataTable is passed in (this is the basis for the source ordinal)
2) The target table is specified (this is the basis for the target ordinal)
3) The target DataTable is calculated from the mappings (only the mapped columns are included).  The basis for this table is neither of the above two, and needs to be reconciled lest you get your mappings all crossed up.

And GenerateColumnMetaData is calculating the target DataTable incorrectly.  It should be in the target table's order, but only including the mapped columns (i.e., sorted by destination ordinal).
Comment 1 Marek Safar 2018-02-22 22:36:03 UTC
Mono 5.10 has significantly improved System.Data implementation which should resolve this issue. If you can still reproduce it please reopen the issue.