This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 200 - Default "splash" image isn't copied to application directory
: Default "splash" image isn't copied to application directory
Status: RESOLVED DUPLICATE of bug 309
Product: iOS
Classification: Xamarin
Component: Tools
: 4.x
: PC All
: --- major
: Untriaged
Assigned To: Alex Corrado
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-08-05 13:37 EDT by Akshay
Modified: 2011-08-19 15:38 EDT (History)
7 users (show)

See Also:
Tags:
Test Case URL:
External Submit: ---


Attachments

Description Akshay 2011-08-05 13:37:58 EDT
Default.png file isn't being copied into the output application directory any
more, thus there is no more splash image.

To get around this, one has to manually create custom Post Build commands to
just get it working on the Simulators, but Device builds are too complicated
for this to be done easily.
Comment 1 Michael Hutchinson 2011-08-05 13:40:05 EDT
This is a bug in MD 2.6 b3, you can work around it by using MD stable (2.4.x)
or MD 2.6 b2. It's fixed in the upcoming 2.6 b4.
Comment 2 Ken Budris 2011-08-11 09:32:26 EDT
Does this bug affect ALL images in the root directory?
Comment 3 Michael Hutchinson 2011-08-11 09:43:49 EDT
All Content files, yes.
Comment 4 Ian 2011-08-17 15:03:51 EDT
The problem is not fixed in 2.6 R1

Several people are having similar issues with R1, see:

http://stackoverflow.com/questions/7084502/monotouch-default-png-not-being-added-to-app-bundle
Comment 5 Ken Budris 2011-08-17 15:19:55 EDT
I agree. I tried with MD 2.6 RC1 and MT 4.0.4.1 and am still having the
problem. By the way, I did not have the problem with MD 2.6 b3 and MT 4.0.3. I
didn't see the problem until I upgraded MT to 4.0.4.1.
Comment 6 Ian 2011-08-17 15:24:18 EDT
Now that you mention it, the problem came the day I installed 4.0.4.1 MonoTouch
Comment 7 Andrew Harcourt 2011-08-18 02:04:15 EDT
I'm running MonoTouch 4.0.5 and still getting this problem. It's a complete
showstopper for shipping an app, sadly :(
Comment 8 Akshay 2011-08-18 08:44:28 EDT
The bug is with the beta MonoDevelop release. If you use the stable (2.4.x) it
works just fine and Michael posted that its fixed, but for the upcoming beta 4
release.
Comment 9 Andrew Harcourt 2011-08-18 09:19:02 EDT
The bug is also in RC1.

A "Release Candidate" is not a beta; it's a candidate for a stable release.
This release candidate has a show-stopping bug in it that prevents developers
from shipping apps, therefore it should no longer be considered as a candidate
for release.

I'm running MonoDevelop 2.6 RC1 with MonoTouch 4.0.5 (and 4.1, and 4.0.4.1) and
this behaviour is the same as in MonoDevelop 2.6b3. I can build exactly the
same codebase with MonoDevelop 2.6b2 and it works perfectly happily.

Has there been a code change between the shipping of RC1 and now to address
this issue? Please don't mark this case as resolved unless you've verified the
fix.
Comment 10 Ian 2011-08-18 10:54:35 EDT
I can confirm on a MacBook Pro, MonoTouch 4.0.5, Mono 2.10.4 and MonoDevelop
2.6 RC1 that the same problem exists.

We're dead in the water.
Comment 11 Michael Hutchinson 2011-08-18 11:02:57 EDT

*** This bug has been marked as a duplicate of bug 309 ***
Comment 12 Alex Soto 2011-08-19 13:02:17 EDT
Ok guys, I guess i found a workaround, please give this a try

Im running MD 2.6RC1, in order to your content files are being included in the
final bundle, delete them from your project, then save your project close MD,
then reopen MD and add again your content files to your project, don't forget
to mark them as content ;)

this worked for me.

Alex
Comment 13 Miguel de Icaza 2011-08-19 15:38:54 EDT
Michael backported the fix, the next update will have it.

Assigning to Alex, so he can close it when 2.6 RC2 goes out.

Note You need to log in before you can comment on or make changes to this bug.