Bug 19990 - Unable to build android application with package "MvvmCross - Settings Plugin"
Summary: Unable to build android application with package "MvvmCross - Settings Plugin"
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.12.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-05-22 08:27 UTC by Udham Singh
Modified: 2014-10-30 09:24 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Udham Singh 2014-05-22 08:27:05 UTC
Steps to reproduce :

1. Create a simple android application.
2. Add package "MvvmCross - Settings Plugin" by right clicking on project then Add->Add Packages...
3. Build the application.

Actual Result : Getting build error.

Expected Result : Application should build successfully.

Screencast : http://screencast.com/t/EAykY2kgStt

Supplement Info :

Bulid Output log : https://gist.github.com/anonymous/79db864930dc2e94bac5
Ide log : https://gist.github.com/anonymous/30f19517fb51f679fc2e
Error log : https://gist.github.com/anonymous/c7b525673ee0046cff4f


Environment Info :

=== Xamarin Studio ===

=== Xamarin Studio ===

Version 5.0 (build 866)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.4.0 ((no/51469e6)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000202

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 7.2.3.35 (Business Edition)
Hash: 9e24c88
Branch: 
Build date: 2014-05-12 19:42:16-0400

=== Xamarin.Android ===

Version: 4.12.3 (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 500000866
Git revision: 89cfcdd28a9a64d4ddc606f8c4f8e6aaafad610a
Build date: 2014-05-12 14:59:13-04
Xamarin addins: e92a35a9280dede5cbdceaaec0c40c06c163546e

=== Operating System ===

Mac OS X 10.9.2
Darwin MacMini.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64


Regression Status : "NOT A REGRESSION" We are getting same behavior with stable builds as well.
Comment 1 Udham Singh 2014-10-30 09:24:27 UTC
I have checked this issue with latest stable builds (XS 5.5.3 (build 6) and Xamarin.Android 4.18.0.34 ) and getting the same issue.

Screencast : http://www.screencast.com/t/mcbLc3hwU8

Note You need to log in before you can comment on or make changes to this bug.