Bug 19881 - ProductInfoHeaderValue fails to parse User-Agent string without version
Summary: ProductInfoHeaderValue fails to parse User-Agent string without version
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-05-19 00:25 UTC by David Karlaš
Modified: 2014-05-19 04:04 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Karlaš 2014-05-19 00:25:27 UTC
This sample works fine on .Net but fails on mono:

var httpClient = new System.Net.Http.HttpClient();
httpClient.DefaultRequestHeaders.Add("User-Agent", "MonoDevelop (Unix 3.13.0; amd64; en-US; Octokit 0.3.4)");

Problem seems to be in https://github.com/mono/mono/blob/master/mcs/class/System.Net.Http/System.Net.Http.Headers/ProductInfoHeaderValue.cs#L157
Which eats up beginning of comment "(" so on next loop FormatError occurs because parsing commented string...
Comment 1 Marek Safar 2014-05-19 04:04:02 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 19881 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: