Bug 19503 - Process.Start on OS X fails silently for missing file
Summary: Process.Start on OS X fails silently for missing file
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: io-layer (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2014-05-02 23:08 UTC by Mikayla Hutchinson [MSFT]
Modified: 2018-01-05 13:27 UTC (History)
6 users (show)

Tags: bugpool-archive
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2014-05-02 23:08:53 UTC
Repro:
Process.Start ("/some/nonexistent/file");

Expected:
System.ComponentModel.Win32Exception

Actual:
Fails almost silently, only printing an error message to stdout.


This seems to be because Mono invoked "open" for ShellExec, without checking the return value and converting it into an exception. It would be cleaner to do it by using LaunchServices API directly.
Comment 1 Rodrigo Kumpera 2017-10-14 00:38:44 UTC
This is the case.
Comment 2 Ludovic Henry 2017-11-10 15:47:42 UTC
I can reproduce with Mono 5.8.0.40 (2017-10/ce494e3d152).

The root cause of that bug is, on macOS, if we cannot find "/some/nonexistent/file", we will try to execute the command with "/usr/bin/open", which is going to print "The file /some/nonexistent/file does not exist" and fail.

We would need to check for the exit status of "/usr/bin/open" to ensure that we opened the executable successfully.
Comment 3 Alexis Christoforides 2017-11-14 22:50:17 UTC
Candidate fix at https://github.com/mono/mono/pull/6010