Bug 19136 - ThreadAbortException Not finishing Finally block ARM
Summary: ThreadAbortException Not finishing Finally block ARM
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: 3.2.x
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-17 15:28 UTC by nicholas.rudh
Modified: 2018-01-24 21:30 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description nicholas.rudh 2014-04-17 15:28:58 UTC
Overview:
	When running the mono unit tests on my ARM running Linux I get an error when executing block_guard_restore_aligment_on_exit.exe. When I debug the program using Xamarin Studio remote debugging I found that once Thread.Abort is called the Finally block does not finish, instead just throws the exception.

Steps to Reproduce: 
1)	Execute block_guard_restore_aligment_on_exit.exe from the mono unit tests in directory $Top_Dir/mono/tests/

Actual Results: 
	Exception is thrown from the finally block

Expected Results: 
	Finish finally block and because of the Thread.ResetAbort not throw an exception.

Build Date & Platform: platform:
 ARM running PetaLinux v2013.10 (yocto 1.4) 
 Mono version 3.2.8


It seems like this problem was found in Bug #16808, and this test does work on my Ubuntu machine. This makes me think it could be ARM specific, so any help would be great. If you need any more information I can provide it.
Comment 1 Zoltan Varga 2014-04-18 05:30:19 UTC
The relevant functionality is not yet implemented on arm.
Comment 2 nicholas.rudh 2014-04-18 15:30:52 UTC
Thanks for the quick response. Is there an ETA on when this could be implemented, or is there not enogh demand for the fix?
Comment 3 Damien Diederen 2014-06-21 09:55:57 UTC
For the benefit of people googling failing test names:

  finally_block_ending_in_dead_bb.cs => finally_block_ending_in_dead_bb.exe

currently fails for (what seems to be) the same reason, as explained
by Rodrigo Kumpera in:

  http://lists.ximian.com/pipermail/mono-devel-list/2014-June/041675.html
Comment 4 Ludovic Henry 2018-01-24 21:30:59 UTC
The test block_guard_restore_aligment_on_exit.exe has been running on our CI system for quite some time on ARM platforms without any major issue, so considering this bug fixed. If you can still reproduce with latest Mono, please reopen.