Bug 18776 - Frank Krueger's Layout DSL no longer works on device.
Summary: Frank Krueger's Layout DSL no longer works on device.
Status: RESOLVED DUPLICATE of bug 18688
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: 7.2.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-03 04:11 UTC by kevinknoop
Modified: 2014-04-03 09:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Simple test case (1.28 KB, application/octet-stream)
2014-04-03 04:12 UTC, kevinknoop
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 18688

Description kevinknoop 2014-04-03 04:11:17 UTC
I have attached a simple test case using the Layout DSL found here https://gist.github.com/praeclarum/5175100
This works 100% on Xamarin.iOS 7.2.0.
On Xamarin.iOS 7.2.1 this no longer works on a device. I get the exception below. It does however still work on the simulator. I understand JIT on the device is not possible but this does work with 7.2.0 hence me raising this issue.

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: Attempting to JIT compile method '(wrapper delegate-invoke) <Module>:invoke_callvirt_UIView_UIViewController (MonoTouch.UIKit.UIViewController)' while running with --aot-only. See http://docs.xamarin.com/ios/about/limitations for more information.

  at Microsoft.Scripting.Interpreter.FuncCallInstruction`2[MonoTouch.UIKit.UIViewController,MonoTouch.UIKit.UIView].Run (Microsoft.Scripting.Interpreter.InterpretedFrame frame) [0x00000] in <filename unknown>:0
  at Microsoft.Scripting.Interpreter.Interpreter.Run (Microsoft.Scripting.Interpreter.InterpretedFrame frame) [0x0001b] in /Developer/MonoTouch/Source/mono/mcs/class/dlr/Runtime/Microsoft.Dynamic/Interpreter/Interpreter.cs:126
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x0005c] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System.Reflection/MonoMethod.cs:238
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System.Reflection/MethodBase.cs:114
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000d5] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System/Delegate.cs:424
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00018] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System/MulticastDelegate.cs:70
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System/Delegate.cs:398
  at Touch.Layout.Eval (System.Linq.Expressions.Expression expr) [0x00081] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:231
  at Touch.Layout.GetViewAndAttribute (System.Linq.Expressions.Expression expr) [0x0020a] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:208
  at Touch.Layout.GetRight (System.Linq.Expressions.Expression expr) [0x00194] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:112
  at Touch.Layout.CompileConstraint (System.Linq.Expressions.BinaryExpression expr, MonoTouch.UIKit.UIView constrainedView) [0x0007a] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:52
  at Touch.Layout+<ConstrainLayout>c__AnonStorey0.<>m__0 (System.Linq.Expressions.BinaryExpression e) [0x00007] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:28
  at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[System.Linq.Expressions.BinaryExpression,MonoTouch.UIKit.NSLayoutConstraint].MoveNext () [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.ToArray[NSLayoutConstraint] (IEnumerable`1 source) [0x00000] in <filename unknown>:0
  at Touch.Layout.ConstrainLayout (MonoTouch.UIKit.UIView view, System.Linq.Expressions.Expression`1 constraints) [0x0003a] in /Users/kevinknoop/Projects/LTest/LTest/Layout.cs:28
  at LTest.LTestViewController.ViewDidLoad () [0x001ef] in /Users/kevinknoop/Projects/LTest/LTest/LTestViewController.cs:33
  at at (wrapper managed-to-native) MonoTouch.UIKit.UIApplication:UIApplicationMain (int,string[],intptr,intptr)
  at MonoTouch.UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String delegateClassName) [0x0004c] in /Developer/MonoTouch/Source/monotouch/src/UIKit/.pmcs-compat.UIApplication.cs:38
  at LTest.Application.Main (System.String[] args) [0x00008] in /Users/kevinknoop/Projects/LTest/LTest/Main.cs:16
Comment 1 kevinknoop 2014-04-03 04:12:17 UTC
Created attachment 6480 [details]
Simple test case
Comment 2 Sebastien Pouliot 2014-04-03 09:09:07 UTC

*** This bug has been marked as a duplicate of bug 18688 ***