Bug 1873 - Regression: Mono.Debugging.Evaluation.EvaluatorException: Method `.ctor' not found in type `CollectionDebuggerView`1'.
Summary: Regression: Mono.Debugging.Evaluation.EvaluatorException: Method `.ctor' not ...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-04 06:06 UTC by Marek Safar
Modified: 2011-11-16 13:54 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2011-11-04 06:06:37 UTC
using System.Collections.Generic;
using System.Globalization;

class A
{
	public static void Main ()
	{
		var v = new List<int> () { 4, 3 };
		return;  // Watch v variable, full type view is displayed instead of DebuggerTypeProxy
	}
}
Comment 1 Miguel de Icaza [MSFT] 2011-11-14 15:56:07 UTC
Tested this with MonoDevelop 2.8.2 with Mono 2.10.6

This seems to be a bug with Mono/master
Comment 2 Zoltan Varga 2011-11-16 10:29:42 UTC
Can't reproduce this with mono master + md master.
Comment 3 Zoltan Varga 2011-11-16 13:54:35 UTC
Fixed in HEAD.