Bug 18690 - Microsoft.Portable.Common.targets is missing in mono 3.4.0 tarball
Summary: Microsoft.Portable.Common.targets is missing in mono 3.4.0 tarball
Status: RESOLVED FIXED
Alias: None
Product: Tools
Classification: Mono
Component: xbuild (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
: 18722 18829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-01 07:31 UTC by Timotheus Pokorra
Modified: 2014-08-16 05:18 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Timotheus Pokorra 2014-04-01 07:31:15 UTC
this file is missing:
https://github.com/mono/mono/blob/mono-3.4.0-branch/mcs/tools/xbuild/targets/Microsoft.Portable.Common.targets

in http://download.mono-project.com/sources/mono/mono-3.4.0.tar.bz2

The other part of the commit https://github.com/mono/mono/commit/76d4e2ad1e7b8e19983a282e652e4266cf3fe0f6 that introduced the file, the change to the Makefile, is included though.

I don't know what change is needed to add new files to make dist.
Perhaps Microsoft.Portable.Common.targets needs to be added to EXTRA_DISTFILES in mcs/tools/xbuild/Makefile
Comment 1 Mikayla Hutchinson [MSFT] 2014-04-01 17:45:24 UTC
Should be fixed by https://github.com/mono/mono/commit/c4667496bf3a82b91173c07a761d1dcbf935edf9
Comment 2 Mikayla Hutchinson [MSFT] 2014-04-01 18:20:08 UTC
Backported to 3.4 branch.
Comment 3 Marek Safar 2014-04-02 01:55:03 UTC
*** Bug 18722 has been marked as a duplicate of this bug. ***
Comment 4 Mikayla Hutchinson [MSFT] 2014-04-06 14:16:17 UTC
*** Bug 18829 has been marked as a duplicate of this bug. ***
Comment 5 delcypher 2014-05-01 10:38:59 UTC
I just ran into this issue. I have no problem using git but someone should really re-generate the packaged tarball because (http://download.mono-project.com/sources/mono/mono-3.4.0.tar.bz2) is still broken.

Distributions often build their packages directly from source tarballs so you're making unnecessary work for them by not fixing this.
Comment 6 Mikayla Hutchinson [MSFT] 2014-05-09 18:48:00 UTC
FYI this has been cherry picked to the 3.4 branch so the next tarball from that branch should include it.

https://github.com/mono/mono/commit/c68c72144d7b2a0516276137855d4508a3f59a17
Comment 7 Matthias Mailänder 2014-06-08 04:13:08 UTC
This is still not resolved. We can't release with a broken tarball https://build.opensuse.org/request/show/236547
Comment 8 Timotheus Pokorra 2014-06-20 01:19:03 UTC
I have now set up a nightly test build for make dist, and a test build of an RPM. This should avoid issues like this in the future.
more details: http://lists.ximian.com/pipermail/mono-packagers-list/2014-June/000216.html
Comment 9 Matthias Mailänder 2014-06-20 01:22:59 UTC
Good idea. Thanks.
Comment 10 Cam Tenny 2014-08-04 18:17:14 UTC
Hi - I also just ran into this. Despite it being marked resolved fixed, the tarball on the website (http://download.mono-project.com/sources/mono/mono-3.4.0.tar.bz2) has not been regenerated.
Comment 11 Timotheus Pokorra 2014-08-13 04:14:23 UTC
There is now a new tarball, for version 3.6.0, and it works fine!

http://download.mono-project.com/sources/mono/mono-3.6.0.tar.bz2
Comment 12 Matthias Mailänder 2014-08-16 05:18:40 UTC
I can confirm the fix and updated https://build.opensuse.org/request/show/244929 again.