Bug 18654 - lldb processes are left running after stopping the debugger
Summary: lldb processes are left running after stopping the debugger
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on: 19732
Blocks:
  Show dependency tree
 
Reported: 2014-03-30 05:08 UTC by Kent
Modified: 2014-08-22 15:15 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Output of ps ajx (59.24 KB, text/plain)
2014-04-02 20:54 UTC, Kent
Details
Console output (5.49 KB, text/plain)
2014-04-02 20:54 UTC, Kent
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kent 2014-03-30 05:08:29 UTC
Every time I finish a debug session in the simulator, an lldb process is left running on my machine. Eventually, I have so many I need to either kill them all or restart my machine.
Comment 1 Sebastien Pouliot 2014-03-30 10:28:16 UTC
Can you provide us with all the software version information ?

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 2 Kent 2014-03-30 20:12:54 UTC
Sure, here you go:

=== Xamarin Studio ===

Version 4.3.4 (build 0)
Installation UUID: f9522136-a8cf-42ce-9c1a-403970fc60e9
Runtime:
	Mono 3.2.7 ((no/40f92d5)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302070000

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.Android ===

Version: 4.12.1 (Indie Edition)
Android SDK: /Users/kent/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: 7.2.1.25 (Indie Edition)
Hash: 46b2486
Branch: 
Build date: 2014-03-24 15:04:26-0400

=== Build Information ===

Release ID: 403040000
Git revision: e2e118a56ebf05c9f15eafbf53379bdebded727c
Build date: 2014-03-12 15:39:07-04
Xamarin addins: 9f2eb9aed862e28ca23d2d2f34e22952087e6e4c

=== Operating System ===

Mac OS X 10.9.2
Darwin krang 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-04-02 13:06:26 UTC
A few more questions:

* Do the lldb processes go away if you quit Xamarin Studio and/or the iOS Simulator?
* Can you execute the following (with a few lldb processes running) in a Terminal and attach the output:

    ps ajx

* Does this happen with any iOS project, or just one in particular (this is easy to test by just creating a new project from a template)?
* Is anything printed to your Mac's Console app (you can find it in Applications/Utilities/Console.app) with the "All Messages" node selected on the left?
Comment 4 Kent 2014-04-02 20:53:29 UTC
> Do the lldb processes go away if you quit Xamarin Studio and/or the iOS
Simulator?

No.

> Can you execute the following (with a few lldb processes running) in a
Terminal and attach the output:   ps ajx

See attachment.

> Does this happen with any iOS project, or just one in particular (this is
easy to test by just creating a new project from a template)?

Yes. Starting with no lldb processes, I created a fresh project using master/detail iOS template. Immediately ran and stopped several times and had 3 lldb processes.

> Is anything printed to your Mac's Console app (you can find it in
Applications/Utilities/Console.app) with the "All Messages" node selected on
the left?

Started with a clean console. Started the same project mentioned above, immediately stopped it. Copied console output and also attached it.
Comment 5 Kent 2014-04-02 20:54:30 UTC
Created attachment 6474 [details]
Output of ps ajx
Comment 6 Kent 2014-04-02 20:54:54 UTC
Created attachment 6475 [details]
Console output
Comment 7 Jeffrey Stedfast 2014-04-02 22:39:04 UTC
since when do we start lldb? is lldb starting due to a runtime crash?
Comment 8 Rolf Bjarne Kvinge [MSFT] 2014-04-03 10:09:31 UTC
lldb is started due to mtouch-64 hitting an abort in native (Objective-C) code.

I'll look into it.
Comment 9 Rolf Bjarne Kvinge [MSFT] 2014-06-13 20:57:24 UTC
Fixed.

mtouch will no longer try to print stack traces when it crashes using gdb/lldb.

monotouch/master: d00ef0cac1e83250f576989193c4c2b141ae4b26
Comment 10 Sky 2014-08-22 15:11:08 UTC
May I ask if this has been fixed in a recent release as I have essentially the same issue?
Comment 11 Sebastien Pouliot 2014-08-22 15:15:33 UTC
@Sky, it's part of the upcoming 7.4.0 release (presently in beta).