Bug 18568 - 'Add files' points ot the initial directory after first use
Summary: 'Add files' points ot the initial directory after first use
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Management (show other bugs)
Version: 4.3.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Vsevolod Kukol
URL:
Depends on:
Blocks:
 
Reported: 2014-03-25 07:15 UTC by Maciej Czechowski
Modified: 2016-07-14 17:55 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Maciej Czechowski 2014-03-25 07:15:37 UTC
Repro steps:
1. Load a solution, choose a directory inside a project, right-click and 'Add|Add Files...'
   The finder window correctly points to the selected directory

2. Choose a file and add it

3. Choose another directory and do the 'Add Files...' again
   Studio will point to the directory selected in (1) not (3)

This becomes very irritating, since we must synchronize mobile projects after changes in the other platform ones.
This means we must either enable 'Display all files' and include them that way (but when the number of project/files in very large in becomes messy) or browse manually to the correct directory after each addition.
Comment 1 Mohit Kheterpal 2014-03-25 08:36:45 UTC
Today I have tried to reproduce this issue but I am unable to reproduce this issue. I have followed the following steps :

1. Create sample android application in XS
2. Add a file in Asset folder from directory 1.
3. Add another file in different folder from directory 2.
4. Again try to add file then it opens directory 2 to add another file.

Screencast : http://screencast.com/t/wgtruNxSxG

Please let me know if have missed some steps or I have to follow different steps to reproduce this issue.
Comment 2 Maciej Czechowski 2014-03-25 09:06:09 UTC
Hello,
the case is about adding existing files, which lay under the project tree.
Please see: http://www.screencast.com/t/kfZhO0a3

First, when I add the file from the 'xx' directory it starts from the 'xx'.
Then, when I try t add the file under 'yy' the finder still points me to 'xx'.
Comment 3 Mohit Kheterpal 2014-03-25 10:08:56 UTC
Thanks Maciej.

We are also getting same behavior as shown in screencast mentioned in comment 2.

Hence marking it as confirmed.
Comment 4 Lluis Sanchez 2015-08-31 05:33:04 UTC
Related to bug #8506. We need a consistent solution for remembering folder locations.
Comment 5 Marius Ungureanu 2016-07-06 14:22:08 UTC
Would having the popup use the last selection location for Projects (but the project location on the first run), but use the folder location for folders work?
Comment 6 xamarin-release-manager 2016-07-14 13:41:44 UTC
Fixed in version 6.2.0.179 (master)

Author: Vsevolod Kukol
Commit: 92f550248c0f3b2a1275d383e61a5cf1fe71cb62 (mono/monodevelop)
Comment 7 xamarin-release-manager 2016-07-14 14:01:44 UTC
Fixed in version 6.1.0.5235 (cycle8)

Author: Vsevolod Kukol
Commit: 92f550248c0f3b2a1275d383e61a5cf1fe71cb62 (mono/monodevelop)