Bug 18555 - mono can't find MonoPosixHelper when not installed in a /usr or /usr/local
Summary: mono can't find MonoPosixHelper when not installed in a /usr or /usr/local
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.2.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-03-24 13:17 UTC by Gaëtan Lehmann
Modified: 2018-01-24 20:56 UTC (History)
4 users (show)

See Also:
Is this bug a regression?: ---
Last known good build:

use full path to libMonoPosixHelper (698 bytes, application/octet-stream)
2014-03-24 13:17 UTC, Gaëtan Lehmann

Description Gaëtan Lehmann 2014-03-24 13:17:14 UTC
Created attachment 6399 [details]
use full path to libMonoPosixHelper

I'm currently packaging mono for homebrew. Homebrew uses a prefix like ${HOMEBREWPREFIX}/Cellar/mono/${VERSION}/ to install mono.

Problem: mono is not able to load libMonoPosixHelper.dylib, because it is not in a system path.

Possible solution: use the full path to this lib in mono/config - see attached patch.
Comment 1 Andrea Canciani 2014-05-28 12:39:51 UTC
Could you check if this PR fixes your issue and causes no further regressions?
Comment 2 Ludovic Henry 2018-01-24 20:56:35 UTC
This was fixed with https://github.com/mono/mono/commit/cdd3d2b7c737aec0b69fac045a01b44884a1d21d and https://github.com/mono/mono/commit/70920b3d66509c7121fb5306a53fd8de62c31159. If you can still reproduce, please reopen.

Note You need to log in before you can comment on or make changes to this bug.