Bug 18430 - Bug with the debugger
Summary: Bug with the debugger
Status: RESOLVED DUPLICATE of bug 25358
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: 3.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2014-03-17 14:54 UTC by Alain
Modified: 2015-01-07 00:39 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 25358

Description Alain 2014-03-17 14:54:12 UTC
In debug mode, I have a problem. in a foreach loop, variables displayed are always NULL when they are properly fulfilled.

Alain
Comment 1 Zoltan Varga 2014-03-17 15:13:28 UTC
Please write some reproduction instructions and a testcase if possible.
Comment 2 Zoltan Varga 2014-03-20 22:43:01 UTC
-> NEEDINFO.
Comment 3 Alain 2014-03-21 04:01:57 UTC
Hi Zoltan,

I have a master project that contains a project with a DLL which I refer in my prjet reference (not by reference to the project, but the DLL file). 

When I debugged a function contained in my DLL. it works normally, except in foreach loops with a structure, the variable used for the foreach is always null when it is busy. 

I do not have time to make an example for you now. 

Alain
Comment 4 David Karlaš 2015-01-07 00:39:24 UTC
This is actually mcs bug

*** This bug has been marked as a duplicate of bug 25358 ***