Bug 18319 - "Child" WCF service call issue
Summary: "Child" WCF service call issue
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies (show other bugs)
Version: 3.2.x
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-03-12 10:37 UTC by Michael Ayvazyan
Modified: 2014-04-21 14:10 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Michael Ayvazyan 2014-03-12 10:37:53 UTC
Recently we ported our .NET application to Mono.
I'd like to say it wasn't hard at all. Most of the things are working like a charm on Mono. 
Our application is heavily using WCF services. We found the following issue.

If one WCF service calls "second" service, it will work just fine.
But if "second" service will call "third" service, it will fail with timeout exception.
If we change "second" servie to call "third" service in a separate thread, it will work just fine.

Basic "demo" available at https://github.com/mayvazyan/MonoWcfIssueDemo
Would you please look into this?


Mono JIT compiler version 3.2.8 (tarball Sat Feb 22 13:06:17 UTC 2014)
Linux raspberrypi 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux


It's working the same way on WIndows 8.1 under Mono 3.2.3 as well.
Comment 1 Michael Ayvazyan 2014-03-26 15:21:14 UTC
Any chance it will be fixed?
Comment 2 Michael Ayvazyan 2014-04-21 14:10:15 UTC
Workaround for the above issue is to use Net TCP binding instead of Basic HTTP.

Note You need to log in before you can comment on or make changes to this bug.