Bug 18203 - Build error - Could not find SDK Directory
Summary: Build error - Could not find SDK Directory
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: 0.x Insider Preview
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-03-05 19:32 UTC by cmarrades
Modified: 2014-03-06 07:26 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build error screenshot (10.17 KB, image/png)
2014-03-05 19:32 UTC, cmarrades
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description cmarrades 2014-03-05 19:32:09 UTC
Created attachment 6235 [details]
Build error screenshot

Hi,

I get the following error when compiling:

Error	1	error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\César\AppData\Local\Android\android-sdk'. 

	
Could be related with the current user name? It´s "César", but the path resolves to a different one...
Comment 1 Sadik Ali 2014-03-06 02:38:21 UTC
I checked this issue on below environments:

Window 7
VS 2013, 12
XA 4.12.0

To check this issue I followed below steps:

1. Created folder with name "César"
2. Put Android SDK into folder "César"
3. Set this SDK path
4. Debug android sample application.
5. Noticed that below error is generated

Error    1    error XA0000: Unexpected error - Please file a bug report at
http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'D:\César\SDK\AndroidSDK'

This is happening when I changed folder name "César"

Refer screen cast: http://screencast.com/t/6AjIUVKUAu
Comment 2 cmarrades 2014-03-06 03:54:23 UTC
Hi, do you have any temporal solution for this issue?

I´m with the trial version of 30 days and can´t really do much with this bug...

Thanks
Comment 3 dean.ellis 2014-03-06 04:04:53 UTC
This is a duplicate of bug 14918. 

For now if you only have 30 days I would use a user (or paths) which do to contain accented characters. 
This is also a problem for the google android tooling see bug https://bugzilla.xamarin.com/show_bug.cgi?id=3943

*** This bug has been marked as a duplicate of bug 14918 ***
Comment 4 cmarrades 2014-03-06 04:07:32 UTC
Hi, 

Thanks for your response.

Is there any way to easily change the "Android SDK folder" without reinstalling, or switching to other user name?
Comment 5 dean.ellis 2014-03-06 04:17:47 UTC
The unified installer always puts the sdk's into the app data directory. I found the best way to avoid this is to manually install the android sdk to somewhere central (like c:\android ) you can then set the SDK location in Tools->Options->Xamarin Android.

You might be able to get away with a copy and paste (try this first) from  

C:\Users\César\AppData\Local\Android

to 

C:\Android

make sure you get both the android-sdk and ndk folders. Then update the settings in Visual Studio.
Comment 6 cmarrades 2014-03-06 07:26:20 UTC
Hi,

Seems it works now.

Thanks.