Bug 18029 - Timeout ignored from HttpReuqestChannel class
Summary: Timeout ignored from HttpReuqestChannel class
Status: RESOLVED DUPLICATE of bug 25251
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies (show other bugs)
Version: 3.2.x
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-26 13:58 UTC by Allie Miller
Modified: 2015-05-21 08:28 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 25251

Description Allie Miller 2014-02-26 13:58:00 UTC
*This report is filed on behalf of a user reporting the issue*

In the attached test project, when initializing a Service Client generated with the Silverlight WCF Proxy Tool, when there is a set timeout take requires more than 60 seconds, the timeout will be ignored from the HttpRequestChannel class:


Timeout Exception that occurs after 60 Seconds:

at
System.ServiceModel.Channels.HttpRequestChannel+HttpChannelRequestAsyncResul
t.WaitEnd () [0x00000] in <filename unknown>:0 

at System.ServiceModel.Channels.HttpRequestChannel.EndRequest (IAsyncResult
result) [0x00000] in <filename unknown>:0 

at System.ServiceModel.Channels.HttpRequestChannel.Request
(System.ServiceModel.Channels.Message message, TimeSpan timeout) [0x00000]
in <filename unknown>:0 

at System.ServiceModel.MonoInternal.ClientRuntimeChannel.Request
(System.ServiceModel.Channels.Message msg, TimeSpan timeout) [0x00000] in
<filename unknown>:0 

at System.ServiceModel.MonoInternal.ClientRuntimeChannel.Request
(System.ServiceModel.Description.OperationDescription od, System.Object[]
parameters) [0x00000] in <filename unknown>:0 

at System.ServiceModel.MonoInternal.ClientRuntimeChannel.DoProcess
(System.Reflection.MethodBase method, System.String operationName,
System.Object[] parameters) [0x00000] in <filename unknown>:0 

at System.ServiceModel.MonoInternal.ClientRuntimeChannel.Process
(System.Reflection.MethodBase method, System.String operationName,
System.Object[] parameters) [0x00000] in <filename unknown>:0

Steps to reproduce the timeout will be included with the test case.

Versioning Information:
Visual Studio 2013
Runtime: Microsoft .NET 4.0.30319.34011
GTK+ 2.24.20 theme: MS-Windows
GTK# (2.12.0.0)
=== Xamarin.Android ===
Version: 4.10.2 (Business Edition)
Android SDK: C:\Users\Serge\AppData\Local\Android\android-sdk
Windows 6.2.9200.0 (64-bit)
Comment 2 Miguel de Icaza [MSFT] 2015-05-21 08:28:54 UTC

*** This bug has been marked as a duplicate of bug 25251 ***