Bug 17748 - Support for continous integration using MSBuild
Summary: Support for continous integration using MSBuild
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Release Readiness (show other bugs)
Version: 1.10.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-13 09:37 UTC by Mats Andreassen
Modified: 2015-07-21 14:30 UTC (History)
7 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mats Andreassen 2014-02-13 09:37:48 UTC
Our company uses TeamCity for continous integration and release building. That means, we want ad-hoc IPA packages being built continously (or nightly) and AppStore IPA built when building for release.

I've been experimenting with MSBuild ( see my post at http://forums.xamarin.com/discussion/3688/how-to-build-ios-app ) but I have not reached my goals.

My suggestments for enhancement are two-fold:

1) Adding support for running the MSBuild target "_RemoteBuild" from the command line, using a dedicated OSX build server. Of course, the resulting IPA package should be available on the machine running the command line build.
2) The Visual Studio plugin should download any IPA packages built from VS to the machine running VS. Not all developers will have desktop or SSH access to their OSX build machine.
Comment 1 Dominique Louis 2014-02-13 10:22:30 UTC
Hi Mats,
  We are working on making this possible in a future release.


D.
Comment 2 Marek Habersack 2014-02-13 11:17:07 UTC
Hi Mats, 
 In addition to Dominique's comment, you can invoke VS IDE in the headless mode to build the application. Start VS command line prompt and issue the devenv /? command - it will show you the list of options you need to use the headless mode.
Comment 3 Arpit Jha 2015-07-14 02:00:27 UTC
I have checked this issue with XVS 3.11.666 and I am able to create iPA file from command line through msbuild . Here is the command:

C:\Users\Saurabh\Documents\Visual Studio 2013\Projects\App179>C:\Windows\Microso
ft.NET\Framework\v4.0.30319\MSBuild.exe /t:Build /p:Configuration=Debug;Platfor
m=iPhone App179.sln

Steps I have followed:
1.Connect VS to mac build host server.
2.Run above command in Command prompt.

If you are still getting the issue please let us know provide the environment info of VS (Windows machine) and XS( Mac machine).
Comment 4 Akhilesh kumar 2015-07-21 14:30:19 UTC
As per comment3, we are unable to reproduce this issue with XVS 3.11.666

So I am closing this issue.

Feel free to reopen it if anyone facing this issue.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.