Bug 17667 - error XA0000: Unexpected error Reason: Could not find SDK directory
Summary: error XA0000: Unexpected error Reason: Could not find SDK directory
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 4.13.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-02-09 08:57 UTC by Ramille
Modified: 2014-02-10 04:12 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Ramille 2014-02-09 08:57:22 UTC
Hello,

I have visual studio 2010 installed and I also installed Xamarin.Android inside of it.

It works well until I try to debug it. This was the error that I got :

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(174,5): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'C:\Users\Céline\Desktop\PR\AndroidApplication2\bin\Debug' not found.

And when I went to check if my directory does exist or not. It did. But I also realised that when I went to c:/users It had created its own folders :

  Céline ( Witch is the correct user name)
  C,line (I don't know if Xamarin made that one or not)
  Céline (witch belonged to the Error above)

So I guess it was normal for the \bin\Debug directory not to be found. So I created a new project in a directory with no accents in it : 

  C:\Andoird Apps\AndroidApplication1

But when I tried to debug it, it gave me this error :

 C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1329,3): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\Céline\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately? [C:\Andoird Apps\AndroidApplication1\AndroidApplication1.csproj]
	
So I thought it was because I installed it on a user account with accents, but was I wrong ? 

Whichever the answer is, I don't know how to fix it... I tried creating a new user but Xamarin.Android wasn't installed on it and I couldn't reinstall it because of a bunch of errors...

So is there an update that I can find maybe ? I'm new in all this so...

Thank-you in advance for your help and sorry if my English was incorrect.
Comment 1 Mikayla Hutchinson [MSFT] 2014-02-09 13:40:46 UTC

*** This bug has been marked as a duplicate of bug 14918 ***
Comment 2 dean.ellis 2014-02-10 04:12:48 UTC
This might also be related to https://bugzilla.xamarin.com/show_bug.cgi?id=16834.

That said even the android tooling has problems in this area see https://bugzilla.xamarin.com/show_bug.cgi?id=3943