Bug 17501 - Math.Round (double.MaxValue, 1) results in Infinity
Summary: Math.Round (double.MaxValue, 1) results in Infinity
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-01-30 02:55 UTC by Atsushi Eno
Modified: 2018-01-24 20:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Atsushi Eno 2014-01-30 02:55:54 UTC
From http://d.hatena.ne.jp/hnw/20140129

double d = Double.MaxValue;
Console.WriteLine(d); // 1.79769313486232E+308
Console.WriteLine(Math.Round(d, 1)); // Infinity

.NET prints 1.79769313486232E+308 but I'm not sure if it is correct.
Comment 1 Ludovic Henry 2018-01-24 20:24:06 UTC
I cannot reproduce with Mono 5.11.0.276 (master/117468d740a). I get the same behavior as on .NET on Windows.