Bug 17381 (vs-504786) - Incorrect reporting of test results
Summary: Incorrect reporting of test results
Status: RESOLVED NOT_REPRODUCIBLE
Alias: vs-504786
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: 4.2.x
Hardware: PC Windows
: Normal normal
Target Milestone: 15.6
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-01-22 14:58 UTC by Mikayla Hutchinson [MSFT]
Modified: 2018-01-10 14:11 UTC (History)
2 users (show)

Tags: vs-sync
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mikayla Hutchinson [MSFT] 2014-01-22 14:58:45 UTC
When I test XS in XS, if I test a single classes, it runs all the tests twice and reports all test results output twice.

If I test a single method in a test class, it runs all the methods of the class. This makes it very difficult to debug individual tests. Worse, the result it reports (pass/fail) for that test is often not correct. I think it's reporting the result of the first test in the class.
Comment 1 Mikayla Hutchinson [MSFT] 2014-01-22 15:44:52 UTC
Running individual tests seems to have been fixed in master.
Comment 2 Mike Krüger 2014-01-23 05:43:25 UTC
Works for me in master as well -> closing that one.
Comment 3 Mikayla Hutchinson [MSFT] 2014-01-23 17:07:40 UTC
It still runs all the tests twice if running tests on a class.
Comment 4 Dmytro Ovcharov 2017-12-21 12:42:56 UTC
I've check that issue. Works for me as well on MonoDevelop 7.4 (build 815)