Bug 17127 - Róbert is not accepted
Summary: Róbert is not accepted
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 4.10.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-01-08 14:45 UTC by Robert Fuszenecker
Modified: 2014-02-09 13:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screen shot (51.53 KB, image/png)
2014-01-13 15:14 UTC, Robert Fuszenecker
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Robert Fuszenecker 2014-01-08 14:45:30 UTC
C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\RĂłbert\App 

______________________________________________________________________________


Build started 2014.01.08. 20:40:33.

__________________________________________________

Project "C:\windows\temp\A2\A2\A2.csproj" (SignAndroidPackage target(s)):



Target _CheckProjectItems:

    CheckProjectItems Task

      NativeLibraries:

      JavaLibraries:

      JavaSourceFiles:

Target _ComputeAndroidAssetsPaths:

      ResourceFiles:

      IntermediateFiles:

Target _GenerateAndroidAssetsDir:

  Skipping target "_GenerateAndroidAssetsDir" because it has no outputs.

Target _ComputeAndroidResourcePaths:

      ResourceFiles:

        Resources\layout\Main.axml

        Resources\values\Strings.xml

        Resources\drawable\Icon.png

      IntermediateFiles:

Target _GenerateAndroidResourceDir:

  Skipping target "_GenerateAndroidResourceDir" because all output files are up-to-date with respect to the input files.

Target _ResolveMonoAndroidSdks:

    MonoAndroid Tools: C:\Program Files (x86)\MSBuild\Xamarin\Android\

    MonoAndroid Binaries: C:\Program Files (x86)\MSBuild\Xamarin\Android\

    Android Platform API level: 15

    TargetFrameworkVersion: v4.0.3

    Android NDK: C:\Program Files\Android\ndk\android-ndk-r8d\

    Android SDK: C:\Users\Róbert\AppData\Local\Android\android-sdk\

    Android SDK Build Tools: C:\Users\Róbert\AppData\Local\Android\android-sdk\build-tools\17.0.0\

    Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39\

Target _ValidateAndroidPackageProperties:

    GetAndroidPackageName Task

      ManifestFile: C:\windows\temp\A2\A2\Properties\AndroidManifest.xml

      AssemblyName: A2

      PackageName: A2.A2

Target _BuildDependencies:

    Resolved library outputs: 

Target _ExtractLibraryProjectImports:

      Assemblies: 

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

      Jars: 

      ResolvedResourceDirectories: 

      ResolvedAssetDirectories: 

      ResolvedEnvironmentFiles: 

Target _GetLibraryImports:

      NativeLibraries: 

      Jars: 

Target _CheckDuplicateJavaLibraries:

      JavaSourceFiles:

      JavaLibraries:

Target _GetAdditionalResourcesFromAssemblies:

      Assemblies: 

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

Target _UpdateAndroidResgen:

      AdditionalResourceDirectories: 

    C:\Users\Róbert\AppData\Local\Android\android-sdk\build-tools\17.0.0\aapt.exe package -f -m -M "C:\Users\Róbert\AppData\Local\Temp\rbrn4kjo.lcy\AndroidManifest.xml" -J "C:\Users\Róbert\AppData\Local\Temp\rbrn4kjo.lcy" --custom-package a2.a2 -F "C:\Users\Róbert\AppData\Local\Temp\rbrn4kjo.lcy\resources.apk.bk" -S obj\Debug\res -I "C:\Users\Róbert\AppData\Local\Android\android-sdk\platforms\android-15\android.jar" --auto-add-overlay 

      AdditionalResourceDirectories:

      Resources:

        C:\windows\temp\A2\A2\obj\Debug\res\layout\main.xml

          [layout\Main.axml]

        C:\windows\temp\A2\A2\obj\Debug\res\values\strings.xml

          [values\Strings.xml]

        C:\windows\temp\A2\A2\obj\Debug\res\drawable\icon.png

          [drawable\Icon.png]

      References:

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

          []

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

          []

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

          []

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

          []

      - Remapping resource: Drawable.icon -> drawable\Icon

      - Not remapping resource: Id.myButton

      - Remapping resource: Layout.main -> layout\Main

      - Not remapping resource: String.app_name

      - Not remapping resource: String.hello

      RemovedDirectories: 

        C:\Users\Róbert\AppData\Local\Temp\rbrn4kjo.lcy

Target GenerateTargetFrameworkMonikerAttribute:

  Skipping target "GenerateTargetFrameworkMonikerAttribute" because all output files are up-to-date with respect to the input files.

Target CoreCompile:

  Skipping target "CoreCompile" because all output files are up-to-date with respect to the input files.

Target CopyFilesToOutputDirectory:

    A2 -> C:\windows\temp\A2\A2\bin\Debug\A2.dll

Target _ConvertDebuggingFiles:

  Skipping target "_ConvertDebuggingFiles" because all output files are up-to-date with respect to the input files.

Target _ResolveAssemblies:

    ResolveAssemblies Task

      ReferenceAssembliesDirectory: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\;;;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Facades\

      I18nAssemblies: 

      LinkMode: None

      Assemblies:

        bin\Debug\A2.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

      Assembly C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll is ignored: system assembly is used instead.

      Assembly C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll is ignored: system assembly is used instead.

      Assembly C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll is ignored: system assembly is used instead.

      Assembly C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll is ignored: system assembly is used instead.

      Assembly C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll is ignored: system assembly is used instead.

      [Output] ResolvedAssemblies:

        C:\windows\temp\A2\A2\bin\Debug\A2.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Mono.Security.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

      [Output] ResolvedUserAssemblies:

        C:\windows\temp\A2\A2\bin\Debug\A2.dll

      [Output] ResolvedFrameworkAssemblies:

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Mono.Security.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

Target _CopyIntermediateAssemblies:

    SourceFiles:

        C:\windows\temp\A2\A2\bin\Debug\A2.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Mono.Security.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

    DestinationFiles:

        obj\Debug\assemblies\A2.dll

        obj\Debug\assemblies\Mono.Android.dll

        obj\Debug\assemblies\mscorlib.dll

        obj\Debug\assemblies\System.Xml.dll

        obj\Debug\assemblies\System.dll

        obj\Debug\assemblies\Mono.Security.dll

        obj\Debug\assemblies\System.Core.dll

    SourceFiles:

        C:\windows\temp\A2\A2\bin\Debug\A2.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Mono.Security.dll

        C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll

    DestinationFiles:

        obj\Debug\assemblies\A2.dll

        obj\Debug\assemblies\Mono.Android.dll

        obj\Debug\assemblies\mscorlib.dll

        obj\Debug\assemblies\System.Xml.dll

        obj\Debug\assemblies\System.dll

        obj\Debug\assemblies\Mono.Security.dll

        obj\Debug\assemblies\System.Core.dll

Target _ResetScanFlag:

  Skipping target "_ResetScanFlag" because all output files are up-to-date with respect to the input files.

Target _ScanAssemblies:

    LinkAssemblies Task

      UseSharedRuntime: true

      MainAssembly: obj\Debug\assemblies\A2.dll

      OutputDirectory: obj\Debug\android\assets\

      I18nAssemblies: 

      ReferenceAssembliesDirectory: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\;;;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Facades\

      ResolvedAssemblies:

        obj\Debug\assemblies\A2.dll

        obj\Debug\assemblies\Mono.Android.dll

        obj\Debug\assemblies\mscorlib.dll

        obj\Debug\assemblies\System.Xml.dll

        obj\Debug\assemblies\System.dll

        obj\Debug\assemblies\Mono.Security.dll

        obj\Debug\assemblies\System.Core.dll

Target _StripEmbeddedLibraries:

      Assemblies: 

        obj\Debug\assemblies\A2.dll

        obj\Debug\assemblies\Mono.Android.dll

        obj\Debug\assemblies\mscorlib.dll

        obj\Debug\assemblies\System.Xml.dll

        obj\Debug\assemblies\System.dll

        obj\Debug\assemblies\Mono.Security.dll

        obj\Debug\assemblies\System.Core.dll

Target _GenerateJavaStubs:

  Skipping target "_GenerateJavaStubs" because all output files are up-to-date with respect to the input files.

Target _AddStaticResources:

    Resource obj\Debug\android\assets\machine.config is unchanged. Skipping.

    Resource obj\Debug\android\src\mono\MonoRuntimeProvider.java is unchanged. Skipping.

    Resource obj\Debug\android\src\mono\android\Seppuku.java is unchanged. Skipping.

Target _GeneratePackageManagerJava:

  Skipping target "_GeneratePackageManagerJava" because all output files are up-to-date with respect to the input files.

Target _CreateBaseApk:

  Skipping target "_CreateBaseApk" because all output files are up-to-date with respect to the input files.

Target _CompileJava:

  Skipping target "_CompileJava" because all output files are up-to-date with respect to the input files.

Target _CompileDex:

  Skipping target "_CompileDex" because all output files are up-to-date with respect to the input files.

Target _BuildApkFastDev:

  Skipping target "_BuildApkFastDev" because all output files are up-to-date with respect to the input files.

Target _Mandroid:

    Mandroid Task

      Assemblies: bin\Debug\A2.dll; C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\Mono.Android.dll; C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll; C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Core.dll; C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.dll; C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\System.Xml.dll

      AndroidEmbedProfilers: 

      I18nAssemblies: 

      BuildDirectory: obj\Debug\

      ReferenceAssembliesDirectory: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v4.0.3\;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\;;;C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\Facades\

      AndroidSdkDirectory: C:\Users\Róbert\AppData\Local\Android\android-sdk\

      JavaSdkDirectory: C:\Program Files (x86)\Java\jdk1.6.0_39\

      AssetDirectory: obj\Debug\assets\

      AndroidSdkPlatform: 15

      MonoAndroidToolsDirectory: C:\Program Files (x86)\MSBuild\Xamarin\Android\

      ResourceDirectory: obj\Debug\res\

      ManifestTemplate: C:\windows\temp\A2\A2\Properties\AndroidManifest.xml

      Package: A2.A2

      NativeLibrary: 

      JavaSource: 

      Debug: True

      UseSharedRuntime: True

      SupportedAbis: armeabi;armeabi-v7a;x86

      LinkMode: None

      ExtraArgs:  

    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1329,3): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\RĂłbert\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately?

Done building target "_Mandroid" in project "A2.csproj" -- FAILED.



Done building project "A2.csproj" -- FAILED.



Build FAILED.



C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1329,3): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\RĂłbert\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately?

    0 Warning(s)

    1 Error(s)



Time Elapsed 00:00:01.57


Package creation failed.
Comment 1 Prashant manu 2014-01-13 08:44:23 UTC
Could you please provide us the test case or screenshot for more details. It seems from error details that incorrect SDK path is causing the problem.
Comment 3 Robert Fuszenecker 2014-01-13 15:12:53 UTC
Hi,

My name is Róbert Fuszenecker, that's why Windows 8 generated the user name "Róbert" for me. The SDK has been installed into C:\Users\Róbert\...\, and that multi-byte UTF-8 character could cause the issue.

You can reproduce the issue by creating a user that has a user name with a multi-byte UTF-8 character included (especially ő and ű make challenges :-))

I attach a screen shot, that might help you to identify the problem.

Should you have any questions, please contact me via email or phone (+36-70-281-58-16).

Best wishes,
Róbert Fuszenecker
Comment 4 Robert Fuszenecker 2014-01-13 15:14:49 UTC
Created attachment 5827 [details]
screen shot
Comment 5 Robert Fuszenecker 2014-01-15 08:12:00 UTC
Hot fix:
* I created a symbolic link: c:\users\Róbert -> c:\users\Robert
* the SDK path can be changed with means of the GUI

The inverse of this method can be used for test purposes, the developer doesn't need to create a new user / install the Xamarin Studio / Android SDK many times.
Comment 6 Akhilesh kumar 2014-01-15 09:20:47 UTC
We have checked this issue with SDK path that contains multi-byte UTF-8 character and we are getting same error.

Screencast : http://screencast.com/t/LQuSCCiH9Wwc

IDE Log : https://gist.github.com/Nischalk/19d9e533c7662d91424b

Environment info : 
XS 4.2.2(build 2)
Comment 7 Mikayla Hutchinson [MSFT] 2014-02-09 13:41:46 UTC
.

*** This bug has been marked as a duplicate of bug 14918 ***