Bug 16807 - Assertion should not be reached while run code from debugger.
Summary: Assertion should not be reached while run code from debugger.
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-12-15 15:16 UTC by Sergey Zhukov
Modified: 2018-01-19 19:32 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (2.25 KB, text/x-csharp)
2013-12-15 15:17 UTC, Sergey Zhukov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sergey Zhukov 2013-12-15 15:16:58 UTC
When I run the test from monodevelop debugger, I've got an exception:

Aborted write b1=True, b2=True, b3=False, b4=False, s2=True
Aborted read b1=True, b2=True, b3=False, b4=False, s2=True
Next iter
Aborted write b1=True, b2=True, b3=True, b4=False, s2=True
* Assertion: should not be reached at exceptions-x86.c:891

Stacktrace:

* Assertion: should not be reached at exceptions-x86.c:891

bash: line 1:  7465 Aborted                 (core dumped) /usr/bin/mono --debug --debugger-agent=transport=dt_socket,address=127.0.0.1:49982 "/home/sergey/Projects/OrphanedLockTest/OrphanedLockTest/bin/Debug/OrphanedLockTest.exe"

Mono Runtime Engine version 3.2.7 (master/01b7a50 Sat Dec 14 01:48:49 NOVT 2013)
Copyright (C) 2002-2013 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  x86
	Disabled:      none
	Misc:          softdebug 
	LLVM:          yes(3.4svn-mono-mono/e656cac)
	GC:            sgen

OS: Ubuntu Linux 32 bit
Comment 1 Sergey Zhukov 2013-12-15 15:17:24 UTC
Created attachment 5664 [details]
TestCase
Comment 2 Zoltan Varga 2014-01-21 23:34:41 UTC
This seems to be related to the finally guard trampolines, if I disable MONO_ARCH_HAVE_HANDLER_BLOCK_GUARD in mini-x86.h, it no longer crashes.
Comment 3 Ludovic Henry 2018-01-19 19:32:42 UTC
I cannot reproduce with Mono 5.11.0.276 (master/117468d740a). Work have been done on the finally block guard so it most likely has been fixed. Please reopen if you can still reproduce.