Bug 16668 - Android 4.10.2 Beta breaks iOS in Visual Studio 2013
Summary: Android 4.10.2 Beta breaks iOS in Visual Studio 2013
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-12-08 13:01 UTC by Jim Wilson
Modified: 2016-08-03 15:24 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Jim Wilson 2013-12-08 13:01:24 UTC
The Xamarin.Android 4.10.2 beta installation is breaking iOS in Visual Studio. It's a beta so I know I'm living on the edge... just letting you know it happened :-).

I confirmed it is the beta that broke things by completely uninstalling all of Xamarin, did the standard install, created iOS and Android projects in VS w/ no trouble. Then installed the 4.10.2 beta and verify that iOS is now broken.

The problem is that when I try to view the Xamarin iOS values in the Options dialog or try to access/create an iOS project I get the error message "The 'MonoTouchPackage' package did not load correctly".

I checked the Visual Studio ActivityLog.xml and it contains the error

SetSite failed for package [MonoTouchPackage]
Comment 1 narayanp 2013-12-12 05:35:32 UTC
I have checked this issue and I am able to reproduce this issue. When I am having stable builds (MTVS 1.8.365, X.Android 4.10.1-73) and then I uninstalled stable X.Android and installed beta X.Android 4.10.2-5 and create iOS application getting dialog: http://screencast.com/t/PAnh4niL
Comment 2 PJ 2013-12-12 05:49:04 UTC
Hi Jim,

Unfortunately, this scenario won't be supported. You'll have to use the corresponding Beta 1.10.19 iOS for VS build alongside the beta 4.10.2 Xamarin.Android. 

We're currently working on merging the two VS extensions into a single installer to prevent exactly this type of mismatch in the future, but for now this one will be WONTFIX.
Comment 3 Jim Wilson 2013-12-12 10:16:31 UTC
Thanks for the update ... using both Betas is a reasonable workaround. Thanks again.