Bug 1650 - Create Mac Installer does not let user select any 'extra' options
Summary: Create Mac Installer does not let user select any 'extra' options
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in (show other bugs)
Version: 2.8.1
Hardware: PC Mac OS
: Low normal
Target Milestone: ---
Assignee: Miguel de Icaza [MSFT]
URL:
: 251 2291 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-23 12:26 UTC by Sebastien Pouliot
Modified: 2012-10-25 17:18 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Pouliot 2011-10-23 12:26:51 UTC
'mmp' has a few options* that can be useful to users and allow them to workaround some issues, e.g. bug #1528. However the "Create Mac Installer" UI does not let users specify any extra arguments (like MonoTouch UI allows).

E.g.
* add i18n assemblies (but that would be even better with it's own GUI, like MT)
* --linkskip (which would provide a workaround for #1528)
Comment 1 Sebastien Pouliot 2012-01-10 16:31:57 UTC
*** Bug 251 has been marked as a duplicate of this bug. ***
Comment 2 Jeffrey Stedfast 2012-03-16 17:16:57 UTC
*** Bug 2291 has been marked as a duplicate of this bug. ***
Comment 3 Jeffrey Stedfast 2012-03-16 17:17:38 UTC
MonoMac addin should also provide UI for mmp's  --i18n=VALUE (from bug #2291)
Comment 4 Jeffrey Stedfast 2012-03-16 20:19:10 UTC
I've got UI now for the i18n option and a "Extra args" text field like mtouch has.

Now all I gotta do is implement the MonoMacBuildExtension
Comment 5 Jeffrey Stedfast 2012-10-25 17:18:21 UTC
implemented