Bug 16493 - Coredump in AppDomain.CreateDomain
Summary: Coredump in AppDomain.CreateDomain
Status: RESOLVED DUPLICATE of bug 15064
Alias: None
Product: Runtime
Classification: Mono
Component: Remoting (show other bugs)
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-28 08:52 UTC by Aleksey Sotnikov
Modified: 2013-11-28 18:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test domain-multithread (1.13 KB, text/x-csharp)
2013-11-28 08:52 UTC, Aleksey Sotnikov
Details

Description Aleksey Sotnikov 2013-11-28 08:52:41 UTC
Created attachment 5561 [details]
test domain-multithread

Test creates a AppDomain in a loop in multithreaded mode. Mono crashes with dump after 10-15 minutes. AppDomain is empty and does nothing

 
Command (10 thread, 10 appdomain, 100 loops): mono domain-multithread.exe 10 10 100

Log:
... 
Thread start 8369
Thread start 8370
Thread start 8371
Thread start 8372
* Assertion at mini.c:3999, condition `code' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at System.Runtime.Serialization.FormatterServices.GetSerializableMembers (System.Type,System.Runtime.Serialization.StreamingContext) <0x000c2>
  at System.Runtime.Serialization.Formatters.Binary.CodeGenerator.GenerateMetadataTypeInternal (System.Type,System.Runtime.Serialization.StreamingContext) <0x00192>
  at System.Runtime.Serialization.Formatters.Binary.CodeGenerator.GenerateMetadataType (System.Type,System.Runtime.Serialization.StreamingContext) <0x0006d>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.CreateMemberTypeMetadata (System.Type) <0x0005b>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.GetObjectData (object,System.Runtime.Serialization.Formatters.Binary.TypeMetadata&,object&) <0x009aa>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.WriteObject (System.IO.BinaryWriter,long,object) <0x0005c>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.WriteObjectInstance (System.IO.BinaryWriter,object,bool) <0x00182>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.WriteQueuedObjects (System.IO.BinaryWriter) <0x0003f>
  at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.WriteObjectGraph (System.IO.BinaryWriter,object,System.Runtime.Remoting.Messaging.Header[]) <0x00070>
  at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize (System.IO.Stream,object,System.Runtime.Remoting.Messaging.Header[]) <0x002c9>
  at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize (System.IO.Stream,object) <0x00020>
  at System.Runtime.Remoting.Channels.CADSerializer.SerializeObject (object) <0x000f9>
  at System.AppDomain.GetMarshalledDomainObjRef () <0x0003c>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_object__this__ (object,intptr,intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&) <0xffffffff>
  at System.AppDomain.InvokeInDomain (System.AppDomain,System.Reflection.MethodInfo,object,object[]) <0x0009c>
  at System.Runtime.Remoting.RemotingServices.GetDomainProxy (System.AppDomain) <0x0004f>
  at System.AppDomain.CreateDomain (string,System.Security.Policy.Evidence,System.AppDomainSetup) <0x00205>
  at System.AppDomain.CreateDomain (string) <0x00010>
  at T.thread_start () <0x00104>
  at System.Threading.Thread.StartInternal () <0x000a8>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

* Assertion at mini.c:3999, condition `code' not met

Aborted (core dumped)




OS: Ubuntu 13.10

Mono version:
Mono JIT compiler version 3.2.3 (tarball Ср. нояб. 27 17:04:10 MSK 2013)
Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors.
www.mono-project.com
    TLS:           __thread
    SIGSEGV:       altstack
    Notifications: epoll
    Architecture:  amd64
    Disabled:      none
    Misc:          softdebug 
    LLVM:          supported, not enabled.
    GC:            sgen
Comment 1 Zoltan Varga 2013-11-28 18:59:35 UTC

*** This bug has been marked as a duplicate of bug 15064 ***

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 16493 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: