Bug 16433 - Monotouch Dialog: Radiogroup selection screen does not have a Back button if previous screen has no title
Summary: Monotouch Dialog: Radiogroup selection screen does not have a Back button if ...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: 7.0.4.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-25 02:34 UTC by Joseph Hanna
Modified: 2018-04-04 04:32 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project demonstrating the problem. (1.44 MB, application/zip)
2014-01-13 17:38 UTC, Joseph Hanna
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Joseph Hanna 2013-11-25 02:34:28 UTC
On iOS 6, if the main MT.D screen does not have a Title, then when going to a RadioGroup screen to make a selection, a Back button is not presented.

I understand that if the main MT.D screen was titled “Foo”, then on the RadioGroup screen, the left navigation button should say “< Foo”.  BUT… if the main MT.D screen does not have a title, then at least a default "< Back" button should be presented.

On iOS 7, a default button with "<" is presented. This is not ideal but at least it still works.

Preferrably, a default "< Back" button would be presented for both iOS 6 and iOS 7.
Comment 4 Saurabh 2014-01-13 14:17:40 UTC
Could you please attach the sample project? So that we can reproduce this issue.
Comment 5 Joseph Hanna 2014-01-13 17:38:49 UTC
Created attachment 5830 [details]
Sample project demonstrating the problem.

Run the project using an iOS 6 simulator and see the problem.  Run the project in an iOS 7 simulator and notice it does not have a problem.  Ideally, both iOS 6 and iOS 7 would show "< Back" rather than blank and "<" respectively.
Comment 6 Saurabh 2014-01-14 07:37:06 UTC
I have checked this issue attached sample on iOS6 and iOS7 simulator. And I am able to reproduce this issue. 

For iOS7 simulator:
On running sample to iOS7 simulator, "<" button appears at to of screen to go back.

For iOS6 simulator:
On running sample to iOS7 simulator, "<" button does not appear at top of screen to go back.

Hence, here is the issue that "<" button does not appear at top of screen for iOS6.

Screencast: http://www.screencast.com/t/XxP5Wo4N29

Build info:
Mono 3.2.6
XS 4.2.2
X.iOS 7.0.4.209


hence, marking it as Confirmed.
Comment 7 Alex Soto [MSFT] 2018-04-04 04:32:37 UTC
I have tested the following issue and I cannot reproduce it anymore using MT.D @ 338abfe687d2461536272017ca439b443db5c2ad