Bug 16431 - mono 3.2.5 build fails on Mavericks: System.Collections.Concurrent: No such file or directory
Summary: mono 3.2.5 build fails on Mavericks: System.Collections.Concurrent: No such f...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-24 23:23 UTC by Ryan Schmidt
Modified: 2014-02-15 22:55 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
build log from MacPorts on OS X 10.9 (50.77 KB, application/x-bzip2)
2013-11-24 23:23 UTC, Ryan Schmidt
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ryan Schmidt 2013-11-24 23:23:34 UTC
Created attachment 5523 [details]
build log from MacPorts on OS X 10.9

Sorry, I have no idea what product or component I'm meant to select. I'm trying to compile the mono 3.2.5 source code on OS X 10.9 Mavericks using MacPorts and after awhile it fails with this error:

/bin/sh: line 0: cd: System.Collections.Concurrent: No such file or directory
make[7]: *** [all-recursive] Error 1
make[6]: *** [all-recursive] Error 1
make[5]: *** [all-recursive] Error 1
make[4]: *** [profile-do--net_4_5--all] Error 2
make[3]: *** [profiles-do--all] Error 2
make[2]: *** [all-local] Error 2

The following directories named System.Collections.Concurrent do exist:

$ find work/ -name 'System.Collections.Concurrent'
work//mono-3.2.5/mcs/class/corlib/Documentation/en/System.Collections.Concurrent
work//mono-3.2.5/mcs/class/corlib/System.Collections.Concurrent
work//mono-3.2.5/mcs/class/corlib/Test/System.Collections.Concurrent
work//mono-3.2.5/mcs/class/System/System.Collections.Concurrent
work//mono-3.2.5/mcs/class/System/Test/System.Collections.Concurrent

mono 3.2.4 source code does not appear to exist. mono 3.2.3 source code built successfully on the same system. I diffed the build log from 3.2.3 and the one from 3.2.5 and there weren't any differences in the output from `make` (other than the line number in two warnings) until this error appeared. I'll attach the full 3.2.5 build log from MacPorts.
Comment 1 Zoltan Varga 2013-11-25 06:43:52 UTC
What mono source distribution are you trying to build ? Were is it from ?
Comment 3 Zoltan Varga 2013-11-26 03:01:54 UTC
This was already fixed in d8e44958d4b073ec1ed065b2baaf00a92f863269, which didn't make 3.2.5.
Comment 4 Ryan Schmidt 2013-11-26 03:39:58 UTC
Thanks. I've applied that patch and still get the same error. Are there any other patches I should need to apply to be able to build 3.2.5?
Comment 5 Zoltan Varga 2013-11-26 11:21:07 UTC
That patch only fixes the generation of the source tarball, it doesn't fix the tarball itself. You might have better luck compiling from git:

http://www.mono-project.com/Compiling_Mono_From_Git
Comment 6 Ryan Schmidt 2013-11-27 01:02:23 UTC
Ah. Well for the purposes of updating the mono port in MacPorts, we would really prefer to fetch a tarball, not download a git repository. When should we expect a version with a functional tarball to be released?
Comment 7 Zoltan Varga 2013-11-27 03:34:44 UTC
Hopefully 3.2.6 will have a working tarball.
Comment 8 Timotheus Pokorra 2013-12-04 00:54:57 UTC
Same problem on Linux as well, cannot build 3.2.5 from the official tarball.

I have built a fixed tarball for 3.2.5 and it is available for download here:
http://download.pokorra.de/mono/tarballs/

See also http://www.pokorra.de/2013/12/building-the-latest-mono-and-monodevelop-on-obs/ which explains how to build the tarball yourself.
Comment 9 Daniel Lo Nigro 2013-12-05 02:26:14 UTC
Can't you integrate the patch into the Mono 3.2.5 tarball on the Mono site, or remove the tarball? It's confusing and misleading having a known broken version still available on the Mono site.
Comment 10 JC 2014-01-15 02:04:31 UTC
Timothy, registered just to say... THANK YOU! \

I have been fighting this thing for hours... only to now find your post. And now it seems to have finally compiled correctly. 

Again,
THANKS!
Comment 11 Timotheus Pokorra 2014-01-18 12:43:41 UTC
I noticed that 3.2.6 released yesterday did not include the fix yet, so it will also not build.

I have built a fixed tarball for 3.2.6 and it is available for download here:
http://download.pokorra.de/mono/tarballs/

3.2.7 will have the fix, I just verified the file https://github.com/mono/mono/blob/mono-3.2.7-branch/mcs/class/Facades/Makefile has the line SUBDIRS = $(net_4_5_SUBDIRS)
Comment 12 Rami 2014-01-26 15:34:07 UTC
Just spent a couple of hours trying to build mono. Then I find this. Mono is, by far, the hardest simple thing to build.
Comment 13 Darren 2014-02-15 22:55:28 UTC
Likewise, just lost a couple of hours banging head against make trying to work out why 3.2.6 wouldn't build only to find this.   I really appreciate the work you guys are putting into this but I've had a tough time getting others to adopt because of the hurdle getting mono to build.  I'd suggest pulling the 3.2.6 build from the site till you get it fixed.