Bug 15596 - Hang in VI status area
Summary: Hang in VI status area
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
: 15157 16110 16637 17057 18034 18039 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-22 16:21 UTC by Mikayla Hutchinson [MSFT]
Modified: 2014-03-05 14:40 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Ball of Death (617.86 KB, text/plain)
2014-03-01 02:06 UTC, Astro
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2013-10-22 16:21:05 UTC
A user reported a reproducible hang with the UI thread stuck in layout out the text editor vi status area. It may be a parent/child resize loop.

"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtk_widget_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.SizeAllocate (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at Mono.TextEditor.TextEditor.ResizeChild (Gdk.Rectangle,Mono.TextEditor.TextEditor/EditorContainerChild) [0x000c9] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:263
  at Mono.TextEditor.TextEditor.MoveTopLevelWidget (Gtk.Widget,int,int) [0x0008b] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:197
  at Mono.TextEditor.Vi.ViStatusArea.AllocateArea (Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00067] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViStatusArea.cs:80
  at Mono.TextEditor.Vi.ViEditMode.AllocateTextArea (Mono.TextEditor.TextEditor,Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00009] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViMode.cs:248
  at Mono.TextEditor.TextEditor.OnSizeAllocated (Gdk.Rectangle) [0x00016] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:145
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtksharp_widget_base_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.OnSizeAllocated (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Components.CompactScrolledWindow.OnSizeAllocated (Gdk.Rectangle) [0x00078] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components/CompactScrolledWindow.cs:85
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtk_widget_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.SizeAllocate (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Components.Docking.DockGroupItem.SizeAllocate (Gdk.Rectangle) [0x000bd] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockGroupItem.cs:102
  at MonoDevelop.Components.Docking.DockGroup.SizeAllocate (Gdk.Rectangle) [0x003fd] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockGroup.cs:472
  at MonoDevelop.Components.Docking.DockGroup.SizeAllocate (Gdk.Rectangle) [0x003ca] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockGroup.cs:470
  at MonoDevelop.Components.Docking.DockLayout.SizeAllocate (Gdk.Rectangle) [0x00011] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockLayout.cs:90
  at MonoDevelop.Components.Docking.DockContainer.OnSizeAllocated (Gdk.Rectangle) [0x00062] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockContainer.cs:149
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtksharp_widget_base_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.OnSizeAllocated (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Components.Docking.DockFrame.OnSizeAllocated (Gdk.Rectangle) [0x00003] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Docking/DockFrame.cs:975
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtksharp_widget_base_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.OnSizeAllocated (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Ide.Gui.WorkbenchWindow.OnSizeAllocated (Gdk.Rectangle) [0x00003] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/WorkbenchWindow.cs:115
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x00022, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () [0x00000] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:387
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) [0x007ad] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:291
  at MonoDevelop.Ide.IdeStartup.Main (string[]) [0x00086] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:538
  at Xamarin.Startup.MainClass.Main (string[]) [0x00002] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.13-branch/07afec66/source/md-addins/Xamarin.Startup/Main.cs:10
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <IL 0x0005c, 0xffffffff>
Comment 1 Mike Krüger 2013-10-22 23:37:37 UTC
should be fixed - how did he repro that bug ?
Comment 2 Mikayla Hutchinson [MSFT] 2013-10-23 12:41:23 UTC
Every time the source editor loaded.
Comment 3 Mikayla Hutchinson [MSFT] 2013-11-12 03:06:09 UTC
*** Bug 16110 has been marked as a duplicate of this bug. ***
Comment 4 Mikayla Hutchinson [MSFT] 2013-11-17 18:52:35 UTC
*** Bug 15157 has been marked as a duplicate of this bug. ***
Comment 5 Mikayla Hutchinson [MSFT] 2013-12-06 14:20:47 UTC
*** Bug 16637 has been marked as a duplicate of this bug. ***
Comment 6 Mikayla Hutchinson [MSFT] 2014-01-04 18:00:27 UTC
*** Bug 17057 has been marked as a duplicate of this bug. ***
Comment 7 Karl Nilsson 2014-01-22 16:09:01 UTC
Does anyone know which commit(s) fixed this bug?
Comment 8 Karl Nilsson 2014-01-22 16:28:09 UTC
I just pulled the latest master branch and it is still happening for me. Can't load any text files with vi mode enabled.
Comment 9 Mikayla Hutchinson [MSFT] 2014-01-22 18:33:17 UTC
Should have been https://github.com/mono/monodevelop/commit/c3b5311aa48f0ac40c914521af666ab48acaa478
Comment 10 Mike Krüger 2014-01-23 02:41:02 UTC
Karl: Can you give details ?

Which operating system ?
Can you provide a kill -QUIT <pid> output like that one above ?
Comment 11 Karl Nilsson 2014-01-23 03:34:59 UTC
I'm on OSX here is the full dump from running make run to killing the process:

oryx:monodevelop karlnilsson$ make run
cd main && /Library/Developer/CommandLineTools/usr/bin/make run
PATH="/Library/Frameworks/Mono.framework/Versions/Current/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/sbin:/usr/local/sbin:/Users/karlnilsson/.cabal/bin" PKG_CONFIG_PATH="/Users/karlnilsson/code/kjnilsson/monodevelop/local-config:/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig:" LD_LIBRARY_PATH="" DYLD_FALLBACK_LIBRARY_PATH="/Library/Frameworks/Mono.framework/Versions/Current/lib:/lib:/usr/lib:/Library/Developer/CommandLineTools/usr/lib" MONO_GAC_PREFIX="/usr/local:" MONODEVELOP_LOCALE_PATH="/Users/karlnilsson/code/kjnilsson/monodevelop/main/build/locale" MONODEVELOP_TEST_PROFILE="/Users/karlnilsson/code/kjnilsson/monodevelop/main/build/bin/test-profile"  UBUNTU_MENUPROXY=0 LIBOVERLAY_SCROLLBAR=0 exec -a "monodevelop" /Library/Frameworks/Mono.framework/Versions/Current/bin/mono-sgen --debug /Users/karlnilsson/code/kjnilsson/monodevelop/main/build/bin/MonoDevelop.exe --no-redirect
INFO [2014-01-23 08:28:51Z]: Starting MonoDevelop 4.2.3
INFO [2014-01-23 08:28:51Z]: Running on Mono 3.2.6 ((no/9b58377 Thu Jan 16 17:49:56 EST 2014)
2014-01-23 08:28:51.309 mono-sgen[16719:d07] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
INFO [2014-01-23 08:28:51Z]: Using GTK+ 2.24.23
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Core
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Ide
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.MacPlatform
INFO [2014-01-23 08:28:51Z]: Initializing Runtime Mono 3.2.6
Starting MonoDevelop
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Debugger
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.SourceEditor2
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.DesignerSupport
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Refactoring
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.FSharpBinding
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.XmlEditor
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Deployment
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.AspNet
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.Autotools
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.CSharpBinding
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.VBBinding
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.AspNet.Mvc
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.TextTemplating
INFO [2014-01-23 08:28:51Z]: Add-in loaded: MonoDevelop.VersionControl
   Loading Workbench
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.Deployment.Linux
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.CBinding
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.DocFood
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.ChangeLogAddIn
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.AssemblyBrowser
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.Gettext
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.GtkCore
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.RegexToolkit
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.WebReferences
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.NUnit
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.MonoDeveloperExtensions
INFO [2014-01-23 08:28:52Z]: Add-in loaded: MonoDevelop.VersionControl.Git
      Initializing Main Window
INFO [2014-01-23 08:28:52Z]: Creating DefaultWorkbench
INFO [2014-01-23 08:28:52Z]: Updating Welcome Page from 'http://software.xamarin.com/Service/News'.
INFO [2014-01-23 08:28:53Z]: Add-in loaded: MonoDevelop.VersionControl.Subversion
INFO [2014-01-23 08:28:53Z]: Add-in loaded: MonoDevelop.VersionControl.Subversion.Unix
INFO [2014-01-23 08:28:53Z]: Welcome Page updated.
Full thread dump:

"IO Threadpool worker"
"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.IO.KeventWatcher.Monitor () [0x000b6] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.IO/KeventWatcher.cs:233
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool monitor"
"Threadpool worker"
"Timer-Scheduler"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at System.Threading.WaitHandle.WaitOne (int) [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:392
  at System.Threading.Timer/Scheduler.SchedulerThread () [0x00257] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Timer.cs:385
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<threadpool thread>"
"Background parser"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.WaitForParseJob (int) [0x00008] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2734
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.ParserUpdateThread () [0x0000d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2783
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Background dispatcher"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.Ide.DispatchService.backgroundDispatcher () [0x00062] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/DispatchService.cs:309
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x00022, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:392
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) [0x007d7] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:295
  at MonoDevelop.Ide.IdeStartup.Main (string[],MonoDevelop.Ide.Extensions.IdeCustomizer) [0x0008d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:581
  at MonoDevelop.Startup.MonoDevelopMain.Main (string[]) [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Startup/MonoDevelop.Startup/MonoDevelopMain.cs:17
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <IL 0x0005c, 0xffffffff>
Full thread dump:

"IO Threadpool worker"
"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.IO.KeventWatcher.Monitor () [0x000b6] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.IO/KeventWatcher.cs:233
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool monitor"
"Threadpool worker"
"Timer-Scheduler"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at System.Threading.WaitHandle.WaitOne (int) [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:392
  at System.Threading.Timer/Scheduler.SchedulerThread () [0x00257] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Timer.cs:385
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<threadpool thread>"
"Background parser"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.WaitForParseJob (int) [0x00008] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2734
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.ParserUpdateThread () [0x0000d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2783
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Background dispatcher"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.Ide.DispatchService.backgroundDispatcher () [0x00062] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/DispatchService.cs:309
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x00022, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:392
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) [0x007d7] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:295
  at MonoDevelop.Ide.IdeStartup.Main (string[],MonoDevelop.Ide.Extensions.IdeCustomizer) [0x0008d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:581
  at MonoDevelop.Startup.MonoDevelopMain.Main (string[]) [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Startup/MonoDevelop.Startup/MonoDevelopMain.cs:17
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <IL 0x0005c, 0xffffffff>
INFO [2014-01-23 08:30:17Z]: Add-in loaded: MonoDevelop.ILAsmBinding
INFO [2014-01-23 08:30:18Z]: Add-in loaded: MonoDevelop.HexEditor
Full thread dump:

"IO Threadpool worker"
"Autosave"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.SourceEditor.AutoSave.AutoSaveThread () [0x0000c] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/AutoSave.cs:137
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.Runtime.Remoting.Channels.Tcp.TcpConnectionPool.ConnectionCollector () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:112
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.IO.KeventWatcher.Monitor () [0x000b6] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.IO/KeventWatcher.cs:233
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool monitor"
"Syntax highlighting"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at Mono.TextEditor.Highlighting.SyntaxModeService.ProcessQueue () [0x00053] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Highlighting/SyntaxModeService.cs:349
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Accept_internal (intptr,int&,bool) <IL 0x00023, 0xffffffff>
  at System.Net.Sockets.Socket.Accept () [0x00036] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/Socket.cs:546
  at Mono.Unix.UnixListener.AcceptSocket () [0x0001c] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/Mono.Posix/Mono.Unix/UnixListener.cs:94
  at (wrapper remoting-invoke-with-check) Mono.Unix.UnixListener.AcceptSocket () <IL 0x00038, 0xffffffff>
  at Mono.Remoting.Channels.Unix.UnixServerChannel.WaitForConnections () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/Mono.Posix/Mono.Remoting.Channels.Unix/UnixServerChannel.cs:178
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Accept_internal (intptr,int&,bool) <IL 0x00023, 0xffffffff>
  at System.Net.Sockets.Socket.Accept () [0x00036] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/Socket.cs:546
  at System.Net.Sockets.TcpListener.AcceptSocket () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/TcpListener.cs:189
  at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.WaitForConnections () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpServerChannel.cs:216
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Timer-Scheduler"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at System.Threading.WaitHandle.WaitOne (int) [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:392
  at System.Threading.Timer/Scheduler.SchedulerThread () [0x00257] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Timer.cs:385
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<threadpool thread>"
"Background parser"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.WaitForParseJob (int) [0x00008] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2734
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.ParserUpdateThread () [0x0000d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2783
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"Background dispatcher"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.Ide.DispatchService.backgroundDispatcher () [0x00062] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/DispatchService.cs:309
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Adjustment.gtksharp_gtk_adjustment_set_bounds (intptr,double,double,double,double,double) <IL 0x0002a, 0xffffffff>
  at Gtk.Adjustment.SetBounds (double,double,double,double,double) <IL 0x0000d, 0x00043>
  at Mono.TextEditor.TextArea.SetAdjustments (Gdk.Rectangle) [0x000ff] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextArea.cs:1718
  at Mono.TextEditor.TextArea.OnSizeAllocated (Gdk.Rectangle) [0x0000f] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextArea.cs:1624
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtk_widget_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.SizeAllocate (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at Mono.TextEditor.Vi.ViStatusArea.AllocateArea (Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00057] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViStatusArea.cs:83
  at Mono.TextEditor.Vi.ViEditMode.AllocateTextArea (Mono.TextEditor.TextEditor,Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00009] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViMode.cs:248
  at Mono.TextEditor.TextEditor.OnSizeAllocated (Gdk.Rectangle) [0x00016] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:152
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtksharp_widget_base_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.OnSizeAllocated (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Components.CompactScrolledWindow.OnSizeAllocated (Gdk.Rectangle) [0x00078] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components/CompactScrolledWindow.cs:85
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x00022, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:392
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) [0x007d7] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:295
  at MonoDevelop.Ide.IdeStartup.Main (string[],MonoDevelop.Ide.Extensions.IdeCustomizer) [0x0008d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:581
  at MonoDevelop.Startup.MonoDevelopMain.Main (string[]) [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Startup/MonoDevelop.Startup/MonoDevelopMain.cs:17
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <IL 0x0005c, 0xffffffff>
Full thread dump:

"IO Threadpool worker"
"Autosave"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.SourceEditor.AutoSave.AutoSaveThread () [0x0000c] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/AutoSave.cs:137
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.Runtime.Remoting.Channels.Tcp.TcpConnectionPool.ConnectionCollector () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:112
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.Thread.Sleep_internal (int) <IL 0x00021, 0xffffffff>
  at System.Threading.Thread.Sleep (int) [0x00017] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:420
  at System.IO.KeventWatcher.Monitor () [0x000b6] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.IO/KeventWatcher.cs:233
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool monitor"
"Syntax highlighting"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at Mono.TextEditor.Highlighting.SyntaxModeService.ProcessQueue () [0x00053] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Highlighting/SyntaxModeService.cs:349
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Accept_internal (intptr,int&,bool) <IL 0x00023, 0xffffffff>
  at System.Net.Sockets.Socket.Accept () [0x00036] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/Socket.cs:546
  at Mono.Unix.UnixListener.AcceptSocket () [0x0001c] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/Mono.Posix/Mono.Unix/UnixListener.cs:94
  at (wrapper remoting-invoke-with-check) Mono.Unix.UnixListener.AcceptSocket () <IL 0x00038, 0xffffffff>
  at Mono.Remoting.Channels.Unix.UnixServerChannel.WaitForConnections () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/Mono.Posix/Mono.Remoting.Channels.Unix/UnixServerChannel.cs:178
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"<unnamed thread>"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Sockets.Socket.Accept_internal (intptr,int&,bool) <IL 0x00023, 0xffffffff>
  at System.Net.Sockets.Socket.Accept () [0x00036] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/Socket.cs:546
  at System.Net.Sockets.TcpListener.AcceptSocket () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System/System.Net.Sockets/TcpListener.cs:189
  at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.WaitForConnections () [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpServerChannel.cs:216
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Timer-Scheduler"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at System.Threading.WaitHandle.WaitOne (int) [0x00000] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:392
  at System.Threading.Timer/Scheduler.SchedulerThread () [0x00257] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Timer.cs:385
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"<threadpool thread>"
"Background parser"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne (int,bool) [0x00032] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:379
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.WaitForParseJob (int) [0x00008] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2734
  at MonoDevelop.Ide.TypeSystem.TypeSystemService.ParserUpdateThread () [0x0000d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.TypeSystem/TypeSystemService.cs:2783
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"Threadpool worker"
"Background dispatcher"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.WaitHandle.WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) <IL 0x00030, 0xffffffff>
  at System.Threading.WaitHandle.WaitOne () [0x00015] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/WaitHandle.cs:357
  at MonoDevelop.Ide.DispatchService.backgroundDispatcher () [0x00062] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/DispatchService.cs:309
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source/bockbuild-mono-3.2.6/profiles/mono-mac-xamarin/build-root/mono-3.2.6/mcs/class/corlib/System.Threading/Thread.cs:680
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0004e, 0xffffffff>

"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Adjustment.gtksharp_gtk_adjustment_set_bounds (intptr,double,double,double,double,double) <IL 0x0002a, 0xffffffff>
  at Gtk.Adjustment.SetBounds (double,double,double,double,double) <IL 0x0000d, 0x00043>
  at Mono.TextEditor.TextArea.SetHAdjustment () [0x001b5] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextArea.cs:1681
  at Mono.TextEditor.TextArea.SetAdjustments (Gdk.Rectangle) [0x00002] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextArea.cs:1703
  at Mono.TextEditor.TextArea.OnSizeAllocated (Gdk.Rectangle) [0x0000f] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextArea.cs:1624
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtk_widget_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.SizeAllocate (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at Mono.TextEditor.Vi.ViStatusArea.AllocateArea (Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00057] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViStatusArea.cs:83
  at Mono.TextEditor.Vi.ViEditMode.AllocateTextArea (Mono.TextEditor.TextEditor,Mono.TextEditor.TextArea,Gdk.Rectangle) [0x00009] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor.Vi/ViMode.cs:248
  at Mono.TextEditor.TextEditor.OnSizeAllocated (Gdk.Rectangle) [0x00016] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:152
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Widget.gtksharp_widget_base_size_allocate (intptr,intptr) <IL 0x00024, 0xffffffff>
  at Gtk.Widget.OnSizeAllocated (Gdk.Rectangle) <IL 0x00013, 0x00053>
  at MonoDevelop.Components.CompactScrolledWindow.OnSizeAllocated (Gdk.Rectangle) [0x00078] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components/CompactScrolledWindow.cs:85
  at Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00014, 0x00080>
  at (wrapper native-to-managed) Gtk.Widget.sizeallocated_cb (intptr,intptr) <IL 0x00022, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x00022, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:392
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) [0x007d7] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:295
  at MonoDevelop.Ide.IdeStartup.Main (string[],MonoDevelop.Ide.Extensions.IdeCustomizer) [0x0008d] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:581
  at MonoDevelop.Startup.MonoDevelopMain.Main (string[]) [0x00000] in /Users/karlnilsson/code/kjnilsson/monodevelop/main/src/core/MonoDevelop.Startup/MonoDevelop.Startup/MonoDevelopMain.cs:17
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <IL 0x0005c, 0xffffffff>
make[1]: *** [runmd-sgen] Terminated: 15
make: *** [run] Error 2
Comment 12 Mike Krüger 2014-01-23 04:00:51 UTC
I made a patch that hopefully fixed that issue.

I wasn't able to reproduce that on my machines - therefore I had to guess. It would be very helpful if you can pull the latest master & try it out.
Comment 13 Karl Nilsson 2014-01-23 04:34:33 UTC
I'll give it a try tonight. Thanks. 

I have noticed it doesn't always happen on larger solutions, suggesting some kidn of race condition. I use a new project or a smaller solution to test it.
Comment 14 Karl Nilsson 2014-01-23 15:11:57 UTC
Hi - tried it again with your patch and the same happens. Similar stack trace. What else can I do or provide to assist?
Comment 15 Karl Nilsson 2014-01-23 15:15:00 UTC
It's odd - I can load the entire monodevelop solution fine but if I create a new c# project it hangs when trying to display the Program.cs file.
Comment 16 Mike Krüger 2014-02-04 03:22:21 UTC
I was never able to reproduce the bug with master.

Can you give me a step by step guide or screencast ?

Do you have a retina mac book ?
Comment 17 Mikayla Hutchinson [MSFT] 2014-02-26 20:09:50 UTC
*** Bug 18034 has been marked as a duplicate of this bug. ***
Comment 18 Mikayla Hutchinson [MSFT] 2014-02-26 20:10:52 UTC
There is a possible fix in XS 4.2.4.
Comment 19 Daniel Harman 2014-02-27 08:43:23 UTC
*I had a duplicate bug of this in the tracker and in reply to the question about retina mac book, yes I am on a retina macbook Late 2013 haswell i7.
Comment 20 Mikayla Hutchinson [MSFT] 2014-02-27 15:48:12 UTC
*** Bug 18039 has been marked as a duplicate of this bug. ***
Comment 21 Daniel Harman 2014-02-27 16:14:34 UTC
p.s. its not fixed in 4.2.4 as I had it in 4.3.3
Comment 22 Mikayla Hutchinson [MSFT] 2014-02-27 17:29:51 UTC
4.3.3 is from an alpha branch and is actually older than 4.2.4
Comment 23 Astro 2014-02-27 17:46:00 UTC
when is 4.2.4 coming out?
Comment 24 Mikayla Hutchinson [MSFT] 2014-02-27 18:42:03 UTC
Ah, looks like the commit was in 4.3.3:

https://github.com/mono/monodevelop/commit/3a6f613fba63ef97b392c972e575d46a25be1bda
Comment 25 Mike Krüger 2014-02-28 00:59:26 UTC
Since it doesn't happen for me I can only guess why that can happen.
Maybe a new kill -QUIT output with a recent version may help me.
Comment 26 Astro 2014-03-01 00:34:32 UTC
I just tried 4.3.3 (the alpha build) and it still just crashed.

how do i upload the error log?
Comment 27 Mike Krüger 2014-03-01 01:41:42 UTC
There is an add attachment link at the top.

But if something hangs I need a kill -QUIT <pid> output.
Comment 28 Astro 2014-03-01 02:06:36 UTC
Created attachment 6187 [details]
Ball of Death

it appears as an infinite loop.
Comment 29 Mike Krüger 2014-03-01 03:52:28 UTC
I could need the kill -QUIT output the native trace doesn't help much.

Btw. is there any way for me to reproduce that ? I still can't see the issue.
Comment 30 Karl Nilsson 2014-03-05 04:10:25 UTC
Hi,

XS 4.2.3.59 still exhibits the issue for me. I cannot work out how to get a stack trace using the kill -QUIT command as suggested. kill on OSX does not appear to take a -QUIT param and none of the options I tried produce a mono stack trace. 

Anyhow, I pulled the latest master changes off github and this does seem to work ok now. Are there any changes in between the 4.2.3.59 release and current in this area?
Comment 31 Mikayla Hutchinson [MSFT] 2014-03-05 13:13:07 UTC
The potential fix was in https://github.com/mono/monodevelop/commit/3a6f613fba63ef97b392c972e575d46a25be1bda which should be in 4.2.4.
Comment 32 Mike Krüger 2014-03-05 14:30:27 UTC
mhutch is right that the last patch wasn't in 4.2.3 but in 4.2.4.

I'll close the issue till someone can reproduce it in 4.2.4+
Comment 33 Karl Nilsson 2014-03-05 14:40:38 UTC
ok thanks guys - once you get around to review some of the outstanding PRs for the vi bindings it should cover most of the subset of vi/vim that I use which would be great indeed. :)