This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 15511 - False Compiler errors
: False Compiler errors
Status: RESOLVED FIXED
Product: Compilers
Classification: Mono
Component: C#
: 3.2.x
: PC Mac OS
: --- normal
: ---
Assigned To: Marek Safar
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-10-19 08:25 EDT by S. Ritter
Modified: 2013-10-29 14:22 EDT (History)
2 users (show)

See Also:
Tags:
Test Case URL:
External Submit: ---


Attachments
Full log results (228.39 KB, text/plain)
2013-10-19 20:08 EDT, S. Ritter
Details
Filtered compiler log (29.77 KB, text/plain)
2013-10-19 20:09 EDT, S. Ritter
Details

Description S. Ritter 2013-10-19 08:25:05 EDT
Description of Problem:
No Compiling of JavApi Core system since (?) last update to version 4.0.13b38 
Compiling tells wrong processor directive for single C# classes - but no
preprocessor using.

Steps to reproduce the problem:
1. Take project from https://github.com/RealBastie/JavApi or
https://java.net/projects/javapi
2. Compile (CMD+B)


Actual Results:
compile process failed (wrong processor directive)

Expected Results:
fine build

How often does this happen? 
ever

Additional Information:
Comment 1 Michael Hutchinson 2013-10-19 19:21:10 EDT
Please provide the actual error.
Comment 2 S. Ritter 2013-10-19 20:08:02 EDT
Created attachment 5182 [details]
Full log results
Comment 3 S. Ritter 2013-10-19 20:09:15 EDT
Created attachment 5183 [details]
Filtered compiler log

cat test.log | grep -v "CS1570" | grep -v "CS1572" | grep -v "CS1574" | grep -v
"CS0108" | grep -v "CS0612" | grep -v "CS1587" | grep -v "CS0114" | grep -v
"CS0672" | grep -v "CS1584"
Comment 4 S. Ritter 2013-10-19 20:10:30 EDT
See attachments
Comment 5 Michael Hutchinson 2013-10-21 09:49:21 EDT
.
Comment 6 S. Ritter 2013-10-28 14:11:17 EDT
It is a showstopper - how can I help? When comes BugFix? What can I do?
Comment 7 S. Ritter 2013-10-28 14:39:13 EDT
I used the time to working on quality of project and think I have locate the
compiler problem:

biz.ritter.javapi.lang.Runtime. 
If I remove the line:
        /// <see cref="#addShutdownHook"/>
the compiler works 

... with other errors :(
Comment 8 Marek Safar 2013-10-29 14:22:58 EDT
Fixed in master

Note You need to log in before you can comment on or make changes to this bug.