Bug 15462 - ComboBox dropdown list is clipped by bottom of screen
Summary: ComboBox dropdown list is clipped by bottom of screen
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms (show other bugs)
Version: 2.10.x
Hardware: PC Linux
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-10-17 12:37 UTC by Stephen McConnel
Modified: 2017-09-01 12:16 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test program to demonstrate bug (10.45 KB, application/zip)
2013-10-17 12:37 UTC, Stephen McConnel
Details
proposed fix (diff against 2.10.9 code) (785 bytes, patch)
2013-10-17 12:39 UTC, Stephen McConnel
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stephen McConnel 2013-10-17 12:37:02 UTC
Created attachment 5162 [details]
test program to demonstrate bug

The dropdown list for a ComboBox can be clipped if the control is too close to the bottom of the screen.  This makes items on the list inaccessible.  Windows/.Net behavior in such cases is to move the listbox to display above the ComboBox's textbox instead of below.
I'm attaching a demo program that demonstrates the problem, and a proposed patch which implements behavior similar to that observed in Windows/.Net.
Comment 1 Stephen McConnel 2013-10-17 12:39:08 UTC
Created attachment 5163 [details]
proposed fix (diff against 2.10.9 code)

The bug probably exists in the 3.x code since the code in master appears to be the same as that in 2.10.9 in the relevant places in ComboBox.cs.
Comment 2 Stephen McConnel 2013-10-17 13:17:46 UTC
This is probably the same as https://bugzilla.xamarin.com/show_bug.cgi?id=4712 but with more details to explain why it's important and with a proposed fix.
Comment 3 Miguel de Icaza [MSFT] 2014-02-12 17:27:00 UTC
Setting priority to lowest, since Windows.Forms is no longer being developed actively.
Comment 4 eb1 2014-03-14 13:26:51 UTC
suggested fix is part of PR #943.