Bug 15130 - Cannot step into framework Console.WriteLine
Summary: Cannot step into framework Console.WriteLine
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-10-02 13:27 UTC by Marek Safar
Modified: 2018-04-05 19:58 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Marek Safar 2013-10-02 13:27:44 UTC
http://screencast.com/t/lL40p1zMKbZ

Debugger does not stop into Console.WriteLine when doing Step-info from user code (with enabled framework debugging)
Comment 1 Zoltan Varga 2013-10-02 14:58:07 UTC
So the problem here is that doing a 'step over' on the last line of object:.ctor () skips a lot of code and goes back to Main.
Comment 2 Zoltan Varga 2013-11-02 12:56:51 UTC
So what happens here is xs creates the single step request with the StepFilter.StaticCtor flag set, so we skip the Console:.cctor invocation, and go the next seq point in the Main method, which is the one after the Console.WriteLine () call. This happens because the call to Console:.cctor () is not explicit, so there are only two seq points, one before the WriteLine () call and one after it.
Comment 3 Ludovic Henry 2018-01-19 18:53:43 UTC
Is it still reproducible with latest Mono?
Comment 4 Ludovic Henry 2018-04-05 19:58:01 UTC
Please reopen if you can still reproduce. Thank you.