Bug 15049 (vs-504787) - NUnit tests create "internal error" and do not complete
Summary: NUnit tests create "internal error" and do not complete
Status: RESOLVED NOT_REPRODUCIBLE
Alias: vs-504787
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: 4.1.12
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-27 15:42 UTC by René Ruppert
Modified: 2018-01-10 14:10 UTC (History)
2 users (show)

Tags: vs-sync
Is this bug a regression?: ---
Last known good build:


Attachments
Error (90.49 KB, image/png)
2013-09-27 15:42 UTC, René Ruppert
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description René Ruppert 2013-09-27 15:42:47 UTC
Created attachment 5012 [details]
Error

The project showing the issue can be found at: https://github.com/Krumelur/Pyramid

Open the Unit Test tab, highlight the first row and press the green arrow to run all tests.
Output will be: "Internal error RemotingExceotion: Unix transport protocol".
See screenshot for complete error.

=== Xamarin Studio ===

Version 4.1.12 (build 6)
Installation UUID: b8bdc5a1-348b-4fad-8e4f-4632ee990c59
Runtime:
	Mono 3.2.3 ((no/8d3b4b7)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302030000

=== Apple Developer Tools ===

Xcode 5.0 (3332.25)
Build 5A1413

=== Xamarin.iOS ===

Version: 7.0.1.4 (Indie Edition)
Hash: 4cfca2f
Branch: 
Build date: 2013-20-09 23:14:32-0400

=== Xamarin.Android ===

Version: 4.8.2 (Starter Edition)
Android SDK: /Users/rene/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 401120006
Git revision: a9ae69a4bf37955e4ab4df0cec7804f574c51f72
Build date: 2013-09-25 16:59:37+0000
Xamarin addins: 761ae26f220068dda0b62f0dd2253f617589a8c6

=== Operating System ===

Mac OS X 10.8.5
Darwin renes-imac.fritz.box 12.5.0 Darwin Kernel Version 12.5.0
    Mon Jul 29 16:33:49 PDT 2013
    root:xnu-2050.48.11~1/RELEASE_X86_64 x86_64
Comment 1 Dmytro Ovcharov 2017-12-18 10:52:44 UTC
Can't reproduce this bug on 7.4 Preview (7.4 build 749).