Bug 14839 - TaskFactory.ContinueWhenAny is broken
Summary: TaskFactory.ContinueWhenAny is broken
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-09-18 19:08 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-09-20 13:53 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mikayla Hutchinson [MSFT] 2013-09-18 19:08:20 UTC
The overload of TaskFactory.ContinueWhenAny that takes a Func<T> fails due to a bad cast:

System.InvalidCastException: Cannot cast from source type to destination type.
  at System.Threading.Tasks.TaskActionInvoker+FuncTaskSelected`1[System.String].Invoke (System.Threading.Tasks.Task owner, System.Object state, System.Threading.Tasks.Task context) [0x00000] in /private/tmp/source/bockbuild-xamarin/profiles/mono-mac-xamarin-no-pcl/build-root/mono-3.2.0/mcs/class/corlib/System.Threading.Tasks/TaskActionInvoker.cs:309 
  at System.Threading.Tasks.Task.InnerInvoke () [0x0000b] in /private/tmp/source/bockbuild-xamarin/profiles/mono-mac-xamarin-no-pcl/build-root/mono-3.2.0/mcs/class/corlib/System.Threading.Tasks/Task.cs:505 
  at System.Threading.Tasks.Task.ThreadStart () [0x00097] in /private/tmp/source/bockbuild-xamarin/profiles/mono-mac-xamarin-no-pcl/build-root/mono-3.2.0/mcs/class/corlib/System.Threading.Tasks/Task.cs:406
Comment 1 Marek Safar 2013-09-20 13:53:54 UTC
Fixed in master

Note You need to log in before you can comment on or make changes to this bug.