Bug 1462 - System.IO.Packaging.Package generates invalid relationship ids
Summary: System.IO.Packaging.Package generates invalid relationship ids
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 2.10.x
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-10-12 17:29 UTC by mariok
Modified: 2011-10-17 16:47 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Miguel de Icaza [MSFT] 2011-10-16 12:09:01 UTC
Alan, could you take a look at this comment and get the fix on mono-2-10 and master?
Comment 2 Alan McGovern 2011-10-17 16:03:19 UTC
We don't really validate anything against the OPC spec simply because at the time of writing this section of the framework our support for handling custom Uris was incomplete. If things have improved, I'll look into implementing proper validation.

I'll definitely fix this issue as you've described anyway. Your approach is perfect.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2011-10-17 16:47:43 UTC
This should already be in master + 2.10 branch (it was required for the NuGet support).

https://github.com/mono/mono/commit/968a511c89a94c57272ffd212988152e093287b8
https://github.com/mono/mono/commit/1d149efc1cdb4880182d160f29d51867f9729193