Bug 14529 - EntryElement's input field is misaligned
Summary: EntryElement's input field is misaligned
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 6.9.5.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-08 00:20 UTC by Zhenya
Modified: 2018-04-14 04:25 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (8.95 KB, application/zip)
2017-03-06 16:36 UTC, Alex Soto [MSFT]
Details
Screenshot (173.79 KB, image/png)
2018-04-14 04:22 UTC, Alex Soto [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Zhenya 2013-09-08 00:20:10 UTC
The input field inside EntryElement is created with an incorrect frame which causes image distortion on iPad 2 (at least). The problem is that frame's y coordinate is not an integer. Here is how it is calculated (MonoTouch.Dialog/Element.cs):
float yOffset = (cell.ContentView.Bounds.Height - size.Height) / 2 - 1;

I believe it should be like this instead:
float yOffset = Math.Round((cell.ContentView.Bounds.Height - size.Height) / 2 - 1);

You can see the distortion especially well if you turn on Color Misaligned Images option in the Device Emulator.
Comment 1 Alex Soto [MSFT] 2017-03-06 16:36:26 UTC
Created attachment 20156 [details]
Test Case
Comment 2 Alex Soto [MSFT] 2017-03-06 16:36:48 UTC
I can confirm this issue still exist
Comment 3 Alex Soto [MSFT] 2018-04-14 04:22:47 UTC
Created attachment 26264 [details]
Screenshot
Comment 4 Alex Soto [MSFT] 2018-04-14 04:25:12 UTC
Looks like this is no longer happening as you can see in the image attached in comment #3 with color misaligned images option enabled in the iPad emulator.