Bug 1441 - Keyboard shortcuts (Ctrl+C,Ctrl+V etc.) not work in russian layout
Summary: Keyboard shortcuts (Ctrl+C,Ctrl+V etc.) not work in russian layout
Status: RESOLVED DUPLICATE of bug 5162
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 2.8
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 11253 11874 17956 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-12 03:22 UTC by baurzhan@gmail.com
Modified: 2017-10-05 15:30 UTC (History)
7 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 5162

Description baurzhan@gmail.com 2011-10-12 03:22:13 UTC
When I switch keyboard layout to russian all shortcuts stop working in Monodevelop. To copy & paste text I have to switch to english or use context menu by clicking right mouse button :(
Comment 1 Mikayla Hutchinson [MSFT] 2011-10-12 06:42:11 UTC
This looks like another gtk keymap issue.
Comment 2 baurzhan@gmail.com 2011-10-12 12:02:13 UTC
Is there any solution for this issue? Or is it a bug in GTK?
Comment 3 Jeffrey Stedfast 2011-11-08 17:55:04 UTC
Judging from Michael's comment, it sounds like a bug in GTK - however, we are working hard on fixing a number of GTK bugs on MacOS and Windows.
Comment 4 Mikayla Hutchinson [MSFT] 2012-11-14 18:27:50 UTC

*** This bug has been marked as a duplicate of bug 5162 ***
Comment 5 Mikayla Hutchinson [MSFT] 2013-03-19 11:00:26 UTC
*** Bug 11253 has been marked as a duplicate of this bug. ***
Comment 6 Mikayla Hutchinson [MSFT] 2014-02-23 14:58:40 UTC
*** Bug 11874 has been marked as a duplicate of this bug. ***
Comment 7 Mikayla Hutchinson [MSFT] 2014-02-23 14:58:45 UTC
*** Bug 17956 has been marked as a duplicate of this bug. ***