Bug 14115 - No feedback after selecting "Run Tests"
Summary: No feedback after selecting "Run Tests"
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 8.0 (15.4)
Hardware: PC Windows
: Normal enhancement
Target Milestone: 15.6
Assignee: vsx
URL:
Depends on:
Blocks:
 
Reported: 2013-08-20 11:39 UTC by Allie Miller
Modified: 2018-01-18 20:19 UTC (History)
13 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
This is an example of what I mean by "feedback", when I put my finger it highlights itself. (41.36 KB, image/jpeg)
2013-08-20 16:38 UTC, mlpstingray
Details
When I put my finger on Run Tests no feedback is displayed (37.80 KB, image/jpeg)
2013-08-20 16:48 UTC, mlpstingray
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Allie Miller 2013-08-20 11:39:24 UTC
When clicking on 'Run Tests', there is actually no feedback (similar to the Test clickable list) at all to indicate that the tests are running. Since there is even no feedback for the click itself on Run Tests, when you have tests that takes time, there is no way to know if they are really running or if the device didn't got your click. (e.g. dev kit device are sometimes not responding so well)

Versioning Information:
Visual Studio 2010 (version 10.0.40219.1 SP1Rel) to run the tests, 
Android UnitTest project created with Xamarin Studio v. 4.0.12 (build 3) 
Xamarin.Android: 4.8.1
Comment 2 mlpstingray 2013-08-20 11:49:07 UTC
Actually, it is on Android using Visual Studio, not iOS. I'm not sure if that'd make a difference since it's the NUnitLite UI anyway.
Comment 3 mlpstingray 2013-08-20 16:38:41 UTC
Created attachment 4675 [details]
This is an example of what I mean by "feedback", when I put my finger it highlights itself.
Comment 4 mlpstingray 2013-08-20 16:48:21 UTC
Created attachment 4676 [details]
When I put my finger on Run Tests no feedback is displayed

A feedback could be displayed when the button is clicked Plus something to tell the user the test are currently running, maybe some sort of progress.
Comment 7 mlpstingray 2014-05-27 11:55:34 UTC
Not sure which info is needed, but usually on Android, when you have a list view and click on an item, the item highlight during the click.

This is not the case with "Run Tests" button, that is what I meant when I wrote "no feedback is displayed".
Comment 8 Arpit Jha 2015-07-28 04:46:10 UTC
I have checked this issue and  able to reproduce this.

Steps I have followed to reproduce:

1.Create a Xamarin.Android Unit Test app.
2.Run the app
3.Click Run Tests.

Observed that 'Run Tests' is not selected on clicked  'Run Tests'.

Screencast: http://www.screencast.com/t/kqIXI5QrXRMZ

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00007

Installed Version: Professional

Xamarin   3.11.826.0 (0e96d55)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.5.3 (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.4.0 (1ebb3ca75e5ea92595284cb84c7d29c6e09ce324)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 9 Prashant [MSFT] 2017-09-14 10:33:58 UTC
This issue is still reproducible in v15.4 in VS 2015 and VS for Mac

I believe this has nothing to do with Visual Studio but unit test app, I see same behaviour on VS for Mac
Comment 10 Jon Douglas [MSFT] 2018-01-18 20:19:37 UTC
I believe the better support for this would be through NUnit 3 Xamarin Runners or XUnit Xamarin Runners as for example NUnit leverages Xamarin.Forms to provide a UI for the on-device runner which provides feedback when you hit "Run Tests"

https://github.com/nunit/nunit.xamarin

https://github.com/xunit/devices.xunit

NUnitLite is open source however in which you can make a pull request to make the "Run Tests" GUI a bit more responsive to a touch/click:

https://github.com/xamarin/xamarin-android/tree/master/src/Xamarin.Android.NUnitLite/Gui/Activities

You should be able to get away with applying an Android theme to the respective application/activities which will give a highlight/selection color to most touch events.

Thus I am marking this invalid as there are now many other options and this is open source to contribute to.