Bug 13956 - API Documentation Update keep failing.
Summary: API Documentation Update keep failing.
Status: RESOLVED FIXED
Alias: None
Product: Documentation
Classification: Xamarin
Component: MonoTouch (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2013-08-13 11:40 UTC by Curtis
Modified: 2013-10-16 13:16 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
API Documetation outdated popup (15.62 KB, image/png)
2013-08-13 11:40 UTC, Curtis
Details
Mac Server Log with error messages (502.27 KB, text/plain)
2013-08-13 11:42 UTC, Curtis
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Curtis 2013-08-13 11:40:39 UTC
Created attachment 4619 [details]
API Documetation outdated popup

When I open an iOS project in Visual Studio 2012, I get a popup that says that the API documentation is out of date.  Anyway, I opt to update it.  The parts are downloaded and updating starts.  After about 5 1/2 minutes of this, the output window in Visual studio stops showing progress of the updates.  Please see "Mac Server Log.txt" attachment for details.
Comment 1 Curtis 2013-08-13 11:42:06 UTC
Created attachment 4620 [details]
Mac Server Log with error messages
Comment 2 Miguel de Icaza [MSFT] 2013-08-13 14:52:50 UTC
Jose, can you take a look at this?

The log looks fine, it seems like the merging took place.
Comment 3 Jose Miguel Torres 2013-08-13 18:28:15 UTC
Hi Curtis,

Could you please gist o just copy & paste the results of the following commands:

$ ls /Library/Developer/Shared/Documentation/DocsSets
$ ls $HOME/Library/Developer/Shared/Documentation/DocSets
$ ls $HOME/Platforms/iPhoneOS.platform/Developer/Documentation/DocSets

On the other hand, run:

$ cd $HOME/Library/Developer/Shared/Documentation/DocSets/com.apple.adc.documentation.AppleiOS6.1.iOSLibrary.docset/Contents
and then
$ open .

Now open the Info.pList a let me see what's the version of the CFBundleShortVersionString tag.

FInally, make sure the "SDK_VERSION" variable of the file /Developer/MonoTouch/usr/share/doc/MonoTouch/apple-doc-wizard.sh is 6.1. If it isn't let me know.

Thanks,
Comment 4 Jose Miguel Torres 2013-08-15 15:55:47 UTC
After exchanging some emails with Curtis this is what I found and how we fixed it:

- His DocSet location is at: $HOME/Library/Developer/Shared/Documentation/DocSets. (this is OK)
- I have detected that the apple-doc-wizard.sh scripts is pointing to 6.0 instead of 6.1. Therefore, after mtbserver launches the apple-doc-wizard it downloads and merge the 6.0 docset (see this mtbserver.log line:

Downloading Apple docs from https://devimages.apple.com.edgekey.net/docsets/20120919/com.apple.adc.documentation.AppleiOS6.0.iOSLibrary.xar

- To fix it we can either install the 6.1 doc from XCode or just set the 6.1 variable value to apple-doc-wizard.sh and execute sudo ./apple-doc-wizard.sh.

Anyway, I am about to keep this record opened (and confimed) since I have a couple of suggestions in order to fix this annoying API Doc Sync behavior.
Comment 6 Jose Miguel Torres 2013-08-15 16:34:13 UTC
Recall: After modifying the SDK_VERSION to 6.1 then the user has to execute sudo ./apple-doc-wizard.sh.

Another work around is: 

Open XCOde and go to Xcode menu --> Preferences... 
Then click on Downloads tab and swithc from components to Documentation.
There should be the iOS 6.1 DocSet entry and the most probably is that it is not installed. 
Click on Check and Install button from the Xcode dialog and wait for the iOS 6.1 DocSet to be installed. Then check it out again.
Comment 7 JLee 2013-10-09 16:49:36 UTC
My setup:
Version:	5.0 (5A1413)
  Location:	/Applications/Xcode.app
  Applications:
  Xcode:	5.0 (3332.25)
  Instruments:	5.0 (51166)
  SDKs:
  OS X:
  10,8:	(12D75)
  iOS:
  7,0:	(11A465)
  iOS Simulator:
  6,1:	(10B141)
  7,0:	(11A465)

I'm using paralles vm windows 7 (in bridge-mode).
I have installed the latest version of Xamrin.iOS (Mac & VS) and Xamarin.Studio (Mac).

I always get the message "Apple Api Documentation outdated. Do you want to update". If i choose "yes" nothing happens. I'm not able to deploy to iOS7 Device.

I tried to install 6.1 DocSet manually. But the is no option for add the download DocSet in XCode.

So, I copied the DocSet to pathes: 

/Users/WS_MacMini_JKR/Library/Developer/Shared/Documentation/DocSets
and
/Applications/Xcode.app/Contents/Developer/Documentation/DocSets

The API-Message still appears.
The 6.1 DocSet also doesn't show up in XCode as installed or available.
Comment 8 Jose Miguel Torres 2013-10-10 09:00:21 UTC
Hi JLee, there is a known issue with XCode5 that has been fixed and it will be released soon.
Comment 9 Jose Miguel Torres 2013-10-16 13:16:03 UTC
Fixed in monotouch/master commit e43ffbf209f273242d8df98cbe3938b1e5b57160