Bug 13924 - Debug.WriteLine() produces unnecessary whitespace and redundant output
Summary: Debug.WriteLine() produces unnecessary whitespace and redundant output
Status: RESOLVED DUPLICATE of bug 13538
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 6.4.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-12 12:48 UTC by Jason Hartley
Modified: 2017-03-22 16:43 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
example of superfluous output caused by Debug.WriteLine() (46.46 KB, image/png)
2013-08-12 12:48 UTC, Jason Hartley
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 13538

Description Jason Hartley 2013-08-12 12:48:31 UTC
Created attachment 4610 [details]
example of superfluous output caused by Debug.WriteLine()

For each Debug.WriteLine() three extra lines of output are echoed to the Application Output window for a total of four lines.  Specifically:

1. a line containing the text "[0:]"
2. the intended output preceded with a timestamp (this is the only line that should be output)
3. a line containing the text "[0:]" + the intended output again
4. an empty line

See attached image for an example.

This behavior does not occur with Console.WriteLine().
Comment 1 Yvan Rodrigues 2014-01-20 13:59:23 UTC
Duplicate of #13538
Comment 2 Manuel de la Peña [MSFT] 2017-03-22 16:43:08 UTC

*** This bug has been marked as a duplicate of bug 13538 ***