Bug 13717 - [iOS]Application comes out of debug mode on setting a break point and clicking step into, in iOS simulator
Summary: [iOS]Application comes out of debug mode on setting a break point and clickin...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-08-02 12:26 UTC by GouriKumari
Modified: 2018-04-05 19:57 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Comment 1 PJ 2013-08-05 12:31:48 UTC
Is this the app crashing? Can you see if there's a crash log?
Comment 3 Jeffrey Stedfast 2013-08-05 15:25:42 UTC
This seems to be a bug in the runtime.

We issue a StepInto request and the runtime never emits a new EventSet and instead just continues execution.
Comment 5 Zoltan Varga 2013-08-05 16:38:24 UTC
Does this only happen on ios7 ?
Comment 7 Zoltan Varga 2013-09-16 15:07:53 UTC
Do you have 'Debug project code only' enabled in Preferences/Debugger ? If its enabled, the debugger will only stop single stepping when it reaches user code, i.e. if you put a breakpoint in FinishedLaunching () in AppDelegate.cs at the 
tabBarController = new UITabBarController ();
line, it will be hit when single stepping from the
this.TabBarItem.Image = UIImage.FromBundle ("second");
line in SecondViewController.cs.
Comment 8 Ludovic Henry 2018-01-24 18:52:49 UTC
Is this something you can still reproduce with latest Mono/XI versions?
Comment 9 Ludovic Henry 2018-04-05 19:57:14 UTC
Please reopen if you can still reproduce. Thank you.