Bug 13570 - Mono throws exception trying to read CultureInfo when region is zh-TW
Summary: Mono throws exception trying to read CultureInfo when region is zh-TW
Status: RESOLVED DUPLICATE of bug 13509
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- critical
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-07-29 13:12 UTC by PJ
Modified: 2013-07-29 13:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 13509

Description PJ 2013-07-29 13:12:36 UTC
Steps to reproduce:

1) System Preferences -> Region -> Chinese (Taiwan)
2) csharp -e System.Globalization.CurrentCulture.CurrentCulture

Expected result:

zh-TW

Actual result:

unknown>:0 
  at System.Globalization.CultureInfo.CreateTextInfo (Boolean readOnly) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_TextInfo () [0x00000] in <filename unknown>:0 
  at Mono.Globalization.Unicode.SimpleCollator..ctor (System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Globalization.CompareInfo..ctor (System.Globalization.CultureInfo ci) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_CompareInfo () [0x00000] in <filename unknown>:0 
  at System.String.EndsWith (System.String value, StringComparison comparisonType) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_Parent () [0x00000] in <filename unknown>:0 
  at System.Globalization.TextInfo..ctor (System.Globalization.CultureInfo ci, Int32 lcid, System.Void* data, Boolean read_only) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.CreateTextInfo (Boolean readOnly) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_TextInfo () [0x00000] in <filename unknown>:0 
  at Mono.Globalization.Unicode.SimpleCollator..ctor (System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Globalization.CompareInfo..ctor (System.Globalization.CultureInfo ci) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_CompareInfo () [0x00000] in <filename unknown>:0 
  at System.String.EndsWith (System.String value, StringComparison comparisonType) [0x00000] in <filename unknown>:0 
  at System.Globalization.CultureInfo.get_Parent () [0x00000] in <filename unknown>:0 
  at System.Globalization.TextInfo..ctor (System.Globalization.CultureInfo ci, Int32 lcid, System.Void* data, Boolean read_only) [0x00000] in <filename unknown>:0 

This is a regression in Mono 3.x, reported environment is:

Mono 3.2.1 675bb0f

This breaks everything for anyone with region set to zh-TW, so fairly critical.


I believe mhutch has already identified a patch with a fix, assigning to him.
Comment 1 Mikayla Hutchinson [MSFT] 2013-07-29 13:38:26 UTC

*** This bug has been marked as a duplicate of bug 13509 ***