This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 13540 - use antialiasing prerence --> cannot turn it off any more
: use antialiasing prerence --> cannot turn it off any more
Status: VERIFIED FIXED
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor
: 4.0.10
: Macintosh Mac OS
: Normal normal
: 4.2.4 (from master)
Assigned To: Mike Krüger
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-07-27 12:54 EDT by Alex Rice
Modified: 2014-03-14 02:50 EDT (History)
4 users (show)

See Also:
Tags: gtk
Test Case URL:
External Submit: ---


Attachments
screenshot (enlarged) (25.05 KB, image/png)
2013-07-27 12:54 EDT, Alex Rice
Details
anonymouspro14 no aa (75 bytes, url)
2013-10-12 11:09 EDT, Alex Rice
Details
pragmatapro14 no aa (74 bytes, url)
2013-10-12 11:10 EDT, Alex Rice
Details

Description Alex Rice 2013-07-27 12:54:00 EDT
AA is always on now. My bitmap font (anonymous pro) is not usable when AA is
turned on. The screenshot shows AA artifacts even though the preference is
unchecked.
Comment 1 Alex Rice 2013-07-27 12:54:46 EDT
Created attachment 4464 [details]
screenshot (enlarged)
Comment 2 Mike Krüger 2013-07-29 04:51:33 EDT
Did it work in a former version ? 

I suspect it's a gtk/pango bug - the Antialias property of the cairo context
isn't taken by the font renderer.

(Other things like the folding draw markers respect this setting)
Comment 3 Alex Rice 2013-07-29 13:15:34 EDT
Mike, actually it worked until the very most recent Xamarin Studio update, last
week. That's why I reported it.
It also works fine in Unity-Monodevelop (an older fork of MonoDevelop that is
shipped with Unity game engine.
Thanks for looking into this!
Comment 4 Michael Hutchinson 2013-07-29 13:52:18 EDT
This must have regressed when we updated cairo or pango.
Comment 5 Cody Russell 2013-08-02 12:38:05 EDT
I've been trying to look into this, but I'm having trouble with it still.  I've
tried reproducing outside of MonoDevelop using current and older versions of
gtk/cairo/pango, but cairo_set_antialias(cr, CAIRO_ANTIALIAS_NONE) doesn't seem
to be affecting the text rendering with any versions I've tried.  It always
wants to antialias the text it seems.
Comment 6 Cody Russell 2013-08-04 23:36:06 EDT
https://github.com/xamarin/bockbuild/pull/1
Comment 7 Cody Russell 2013-08-05 14:18:11 EDT
Michael merged my pull request, closing this.
Comment 8 Alex Rice 2013-10-12 11:08:41 EDT
Thanks for fixing the antialiasing setting , looks like that made it into
4.0.13. 
*however* font rendering is really broken now with antialiasing turned off, it
is not usable in it's current state. Here are a couple of screenshots

https://dl.dropboxusercontent.com/u/22076075/monodevelop-pragmatapro14.png
https://dl.dropboxusercontent.com/u/22076075/monodevelop-anonymouspro14.png
Comment 9 Alex Rice 2013-10-12 11:09:24 EDT
Created attachment 5135 [details]
anonymouspro14 no aa
Comment 10 Alex Rice 2013-10-12 11:10:05 EDT
Created attachment 5136 [details]
pragmatapro14 no aa
Comment 11 Mike Krüger 2014-01-31 02:13:44 EST
fixed

I removed the feature - with the current rendering backend turning off AA
doesn't give any usable result. AFAIR the results never were pretty - therefore
it's not something we really want to support.
Comment 12 Cody Russell 2014-02-10 16:35:42 EST
I don't think we need my Cairo patch anymore. I'm removing from bockbuild.
Comment 13 Nischal 2014-03-13 08:38:28 EDT
We have checked and not able to find AA feature in XS. Also as per comment 11
it seems that AA (antialiasing) feature is currently not supported. Please let
us know if there is possibility of this feature in near future or is there any
other directions/suggestions to verify this issue?

Environment Info:
XS 4.2.4 (Build 32)
Build Information
Git revision: a160c35dac9ab9fd32eeadaa171216316d5a5133
Xamarin addins: a779416ceabd54981ce812771a4061c942e8b872
Xam.iOS 7.0.7.2
Mono 3.2.7
Comment 14 Mike Krüger 2014-03-13 10:04:44 EDT
Yes it got removed - it did never really give good drawing results ... it was
implemented more or less to proof something and not as a "real value".
Comment 15 narayanp 2014-03-14 02:50:49 EDT
As per comment#13 and #14 anti-aliasing has removed. So I am closing this
issue.

Note You need to log in before you can comment on or make changes to this bug.