Bug 13475 - Project compiles OK but can't be launched due to invalid characters in the path
Summary: Project compiles OK but can't be launched due to invalid characters in the path
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 4.4.x
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2013-07-25 12:49 UTC by Frédéric Mauroy
Modified: 2014-08-28 12:33 UTC (History)
3 users (show)

See Also:
Is this bug a regression?: ---
Last known good build:

Output of MSBuild (11.98 KB, text/plain)
2013-07-26 04:53 UTC, Frédéric Mauroy

Description Frédéric Mauroy 2013-07-25 12:49:37 UTC
Just created my first project with Xamarin.Android. Compiles OK, but when I want to run it, this error shows up:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(5,5): Error XA0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'C:\Users\Frédéric\Documents\Projects\ZinioArchiver\ZinioArchiver\bin\Debug' not found. (XA0000) (ZinioArchiver)

The correct path should contain "Frédéric" instead of "Frédéric". I suppose there is an invalid encoding somewhere.

I'll try to use the 8.3 notation in the future as a workaround...

Comment 1 Jonathan Pryor 2013-07-25 14:33:04 UTC
Please enable and provide Diagnostic build output:

Comment 2 Frédéric Mauroy 2013-07-26 04:53:54 UTC
Created attachment 4447 [details]
Output of MSBuild
Comment 3 Jonathan Pryor 2014-02-14 09:53:44 UTC
@Frédéric: I don't think Attachment #4447 [details] is Diagnostic build output, as it doesn't contain the `mandroid` command that's being executed.
Comment 4 Frédéric Mauroy 2014-02-14 10:21:47 UTC

I have created a new folder with a plain name (D:\Xamarin) for placing my projects instead of the default VS2K12 project folder (C:\Users\Frédéric\Documents\Visual Studio 2012\Projects) and that solved my issue.

You can easily reproduce the problem by using a special character in the path to the Xamarin project, but in my case, this workaround solved the issue, so as far as I'm concerned, you can close the call.

Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2014-08-28 12:33:22 UTC
Just to do a little bookkeeping: this is most likely a duplicate of bug 14918.

*** This bug has been marked as a duplicate of bug 14918 ***

Note You need to log in before you can comment on or make changes to this bug.