Bug 13475 - Project compiles OK but can't be launched due to invalid characters in the path
Summary: Project compiles OK but can't be launched due to invalid characters in the path
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 4.4.x
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-07-25 12:49 UTC by Frédéric Mauroy
Modified: 2014-08-28 12:33 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Output of MSBuild (11.98 KB, text/plain)
2013-07-26 04:53 UTC, Frédéric Mauroy
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Frédéric Mauroy 2013-07-25 12:49:37 UTC
Just created my first project with Xamarin.Android. Compiles OK, but when I want to run it, this error shows up:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(5,5): Error XA0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'C:\Users\Frédéric\Documents\Projects\ZinioArchiver\ZinioArchiver\bin\Debug' not found. (XA0000) (ZinioArchiver)

The correct path should contain "Frédéric" instead of "Frédéric". I suppose there is an invalid encoding somewhere.

I'll try to use the 8.3 notation in the future as a workaround...

Cheers
fred
Comment 1 Jonathan Pryor 2013-07-25 14:33:04 UTC
Please enable and provide Diagnostic build output:

http://docs.xamarin.com/guides/android/deployment%2c_testing%2c_and_metrics/diagnostics#1.diagnostic-msbuild-output
Comment 2 Frédéric Mauroy 2013-07-26 04:53:54 UTC
Created attachment 4447 [details]
Output of MSBuild
Comment 3 Jonathan Pryor 2014-02-14 09:53:44 UTC
@Frédéric: I don't think Attachment #4447 [details] is Diagnostic build output, as it doesn't contain the `mandroid` command that's being executed.
Comment 4 Frédéric Mauroy 2014-02-14 10:21:47 UTC
Hi,

I have created a new folder with a plain name (D:\Xamarin) for placing my projects instead of the default VS2K12 project folder (C:\Users\Frédéric\Documents\Visual Studio 2012\Projects) and that solved my issue.

You can easily reproduce the problem by using a special character in the path to the Xamarin project, but in my case, this workaround solved the issue, so as far as I'm concerned, you can close the call.

Cheers
fred
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2014-08-28 12:33:22 UTC
Just to do a little bookkeeping: this is most likely a duplicate of bug 14918.

*** This bug has been marked as a duplicate of bug 14918 ***