Bug 13392 - Unable to reference F# PCL from an Android app
Summary: Unable to reference F# PCL from an Android app
Status: RESOLVED DUPLICATE of bug 31933
Alias: None
Product: Android
Classification: Xamarin
Component: Pre-release (show other bugs)
Version: 4.8.x
Hardware: PC Windows
: Highest normal
Target Milestone: 4.10.x
Assignee: Martin Baulig
URL:
Depends on:
Blocks:
 
Reported: 2013-07-22 17:46 UTC by Vagif Abilov
Modified: 2015-07-23 11:28 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 31933

Description Vagif Abilov 2013-07-22 17:46:50 UTC
I have a PCL in F#. It uses Fsharp.Core.dll that resides in C:\Program Files (x86)\Reference Assemblies\Microsoft\FSharp\3.0\Runtime\.NETPortable. It has version 2.3.5.0.

I can successfully reference this PCL from various Windows platforms, but when I add a reference to it to an Android app, it fails to compile giving the following error:

error CS1705: Assembly 'ConwayGame.Portable, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'FSharp.Core, Version=2.3.5.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' which has a higher version than referenced assembly 'FSharp.Core, Version=2.3.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
Comment 1 PJ 2013-11-19 16:38:19 UTC
This bug was targeted for a past milestone, moving to the next active non-hotfix milestone.
Comment 2 Marek Safar 2015-07-23 11:28:43 UTC

*** This bug has been marked as a duplicate of bug 31933 ***