Bug 13336 - Default value of indexer parameter is not read
Summary: Default value of indexer parameter is not read
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Reflection (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Rodrigo Kumpera
URL:
Depends on:
Blocks:
 
Reported: 2013-07-19 04:26 UTC by Piotr Zierhoffer
Modified: 2013-08-22 16:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Source code presenting the problem. (899 bytes, text/x-csharp)
2013-07-19 04:26 UTC, Piotr Zierhoffer
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Piotr Zierhoffer 2013-07-19 04:26:34 UTC
Created attachment 4381 [details]
Source code presenting the problem.

Description of Problem:

When I try to retrieve a default value of an indexer parameter, null is returned. It works on .NET, even if compiled on Mono.

Steps to reproduce the problem:
1. Compile the code attached.
2. Run.


Actual Results:

param
[empty line]
param
test


Expected Results:

param
test
param
test

How often does this happen? 

Always.

Additional Information:

Mono JIT compiler version 3.3.0 (master/442ccb9...)
Comment 1 Marek Safar 2013-07-20 03:37:51 UTC
Rodrigo, this is quite bad. Apart of this issue runtime creates directly ParameterInfo which is wrong because many default property implementations throw or return empty values which is not what .NET does. We need MonoParameterInfo or something similar to be returned in this case.
Comment 2 Rodrigo Kumpera 2013-07-21 17:57:35 UTC
Hi Marek,

PropertyInfo was not converted to 4.0 style reflection with public classes throwing.
Comment 3 Rodrigo Kumpera 2013-07-21 18:23:51 UTC
Fixed the first part of this bug, still need to fix the second one. Which requires introducing a MonoParamInfo and that will be quite some work.
Comment 4 Rodrigo Kumpera 2013-08-22 16:27:55 UTC
Fixed it all.