Bug 13025 - file + line number information don't show up in crash reports when enabling llvm
Summary: file + line number information don't show up in crash reports when enabling llvm
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: 6.3.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-07-02 19:36 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2017-02-28 19:26 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test project (7.53 KB, application/zip)
2013-07-02 19:36 UTC, Rolf Bjarne Kvinge [MSFT]
Details
Test Project (Unified) (11.03 KB, application/zip)
2017-02-28 19:26 UTC, Vincent Dondain [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 13025 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Rolf Bjarne Kvinge [MSFT] 2013-07-02 19:36:07 UTC
Created attachment 4262 [details]
test project

Repro:
* Open attached solution.
* Switch to Release|Device configuration.
* Build & run. It'll crash immediately upon startup.
* Open Xcode and get crash report. Note that no managed files / line numbers show up, for instance:

35  fastdevtest    0x00082034 fastdevtest__fastdevtest_Application_Main_string__ + 44
Comment 1 Vincent Dondain [MSFT] 2017-02-28 19:25:39 UTC
I guess that same line in the crash report from Xcode: https://gist.github.com/VincentDondain/ee726567fea05156def5872648da5541

Also updated the test case to unified (;
Comment 2 Vincent Dondain [MSFT] 2017-02-28 19:26:47 UTC
Created attachment 20040 [details]
Test Project (Unified)