Bug 12918 - Wrong form action after Server.Transfer
Summary: Wrong form action after Server.Transfer
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: master
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-06-27 12:26 UTC by APS
Modified: 2013-06-27 12:26 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 12918 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description APS 2013-06-27 12:26:41 UTC
If I'm in a page with path "/myapp/directory1/mypage1.aspx" and inside code I put a Server.Transfer("../directory2/mypage2.aspx") the request is correctly transferred but the value of the action attribute of the form tag is "directory2/mypage2.aspx" and any subsequent postback fails with the error:
"/myapp/directory1/directory2/mypage2.aspx" doesn't exists

In Microsoft .Net framework and even in Mono 2.0.1 the action attribute takes the value "../directory2/mypage2.aspx" and everything works fine.