Bug 12850 - FtpWebRequest does not handle remote paths properly
Summary: FtpWebRequest does not handle remote paths properly
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 2.10.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Egorbo
URL:
Depends on:
Blocks:
 
Reported: 2013-06-24 13:00 UTC by Bryan Moulton
Modified: 2018-04-09 09:44 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bryan Moulton 2013-06-24 13:00:36 UTC
Related to case #38642
https://bugzilla.novell.com/show_bug.cgi?id=698551

The culprit is here:
https://github.com/mono/mono/blob/master/mcs/class/System/System.Net/FtpWebRequest.cs#L560

It looks like the code is ignoring the last part of the path name because of this line. For file commands this is fine, but if it is a List command the whole path needs to be included.
Comment 1 Tom_Qv 2017-11-12 22:00:21 UTC
just opened a thread in the Xamarin.Mac-forum

https://forums.xamarin.com/discussion/106503/ftpwebrequest-not-working-correct-on-xamarin-mac/p1?new=1

looks like, this is an old bug?
Comment 2 Egorbo 2018-03-17 23:26:10 UTC
PR: https://github.com/mono/mono/pull/7644