Bug 12829 - mono runtime F/libc Fatal signal 4 (SIGILL) on android 4.0.3 lenovo 10''
Summary: mono runtime F/libc Fatal signal 4 (SIGILL) on android 4.0.3 lenovo 10''
Status: RESOLVED DUPLICATE of bug 13957
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 4.7.x
Hardware: PC Windows
: High normal
Target Milestone: 4.8.x (post async)
Assignee: Rodrigo Kumpera
URL:
Depends on: 14011 14013 14017 14019 14042 14043 14045 14050
Blocks:
  Show dependency tree
 
Reported: 2013-06-21 18:31 UTC by softlion
Modified: 2013-08-27 11:51 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
detailed adb logcat (326.95 KB, text/plain)
2013-06-21 18:31 UTC, softlion
Details
atrix sigill 4.7.11 (6.01 KB, text/plain)
2013-06-28 15:46 UTC, T.J. Purtell
Details

Description softlion 2013-06-21 18:31:17 UTC
Created attachment 4177 [details]
detailed adb logcat

A customer was unable to launch my android add. I get one of the tablet today and here the result of the debugging session.

Any program built using 4.7.x displays only the splash screen then go back almost immediatly to the "desktop".
I've tryed both with the default Android Application project built using VS2012 and Xamarin Studio.

I then uninstalled 4.7.x (i tryed with both 4.7.9 and 4.7.10) and installed 4.6.x, and rebuilt and deployed the default project.
It works perfectly.


So: 4.6.x works. 4.7.x crash in libc. Extract of adb logcat (it is always almost the same) follows.
Tablet model:
'Lenovo/ThinkPadTablet/Indigo:4.0.3/ThinkPadTablet_A400_03/0070_0132_WE:user/release-keys'

Any workaround ?
note: 4.7.X work perfectly on my nexus 7 (android 4.2.2) and samsung S3 (android 4.1.2)


I/ActivityManager(  170): Start proc AndroidApplication1.AndroidApplication1 for activity AndroidApplication1.AndroidApplication1/androidapplication1.Activity1: pid=22935 uid=10134 gids={3003, 1015, 1023}mo

I/dalvikvm(22935): Turning on JNI app bug workarounds for target SDK version 8...

D/OpenGLRenderer(  419): Flushing caches (mode 1)

D/OpenGLRenderer(  419): Flushing caches (mode 0)

I/ActivityThread(22935): Pub AndroidApplication1.AndroidApplication1.mono.MonoRuntimeProvider.__mono_init__: mono.MonoRuntimeProvider

D/dalvikvm(22935): Trying to load lib /data/data/AndroidApplication1.AndroidApplication1/lib/libmonodroid.so 0x410f5638

D/dalvikvm(22935): Added shared lib /data/data/AndroidApplication1.AndroidApplication1/lib/libmonodroid.so 0x410f5638

F/libc    (22935): Fatal signal 4 (SIGILL) at 0x5b512150 (code=1)

I/DEBUG   (22477): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

I/DEBUG   (22477): Build fingerprint: 'Lenovo/ThinkPadTablet/Indigo:4.0.3/ThinkPadTablet_A400_03/0070_0132_WE:user/release-keys'

I/DEBUG   (22477): pid: 22935, tid: 22935  >>> AndroidApplication1.AndroidApplication1 <<<

I/DEBUG   (22477): signal 4 (SIGILL), code 1 (ILL_ILLOPC), fault addr 5b512150

I/DEBUG   (22477):  r0 019c3460  r1 5b5c13b8  r2 00000000  r3 0000000b

I/DEBUG   (22477):  r4 5b5c13b8  r5 019c3460  r6 5b5df180  r7 5b5df180

I/DEBUG   (22477):  r8 5b511754  r9 00000000  10 000003af  fp bec3b594

I/DEBUG   (22477):  ip 00000000  sp bec3b4e0  lr 5b512610  pc 5b512150  cpsr 60000050

I/DEBUG   (22477):  d0  000000a043200000  d1  3ff0000043200000

I/DEBUG   (22477):  d2  457ff80000000fff  d3  000000003f000000

I/DEBUG   (22477):  d4  00001fff00000000  d5  3fe999999999999a

I/DEBUG   (22477):  d6  3fe8000000000000  d7  000000a000000000

I/DEBUG   (22477):  d8  0000000000000000  d9  0000000000000000

I/DEBUG   (22477):  d10 0000000000000000  d11 0000000000000000

I/DEBUG   (22477):  d12 0000000000000000  d13 0000000000000000

I/DEBUG   (22477):  d14 0000000000000000  d15 0000000000000000

I/DEBUG   (22477):  scr 80000012

I/DEBUG   (22477): 

I/DEBUG   (22477):          #00  pc 001e4150  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):          #01  lr 5b512610  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477): 

I/DEBUG   (22477): code around pc:

I/DEBUG   (22477): 5b512130 e3750106 1affffdd e1a02008 eaffffd5  ..u...... ......

I/DEBUG   (22477): 5b512140 000c1060 e92d47f0 e5903018 e1a05000  `....G-..0...P..

I/DEBUG   (22477): 5b512150 eef60b08 e5900010 e595800c e0603003  .............0`.

I/DEBUG   (22477): 5b512160 e0232fc3 e0422fc3 ee072a10 e1a03088  ./#../B..*...0..

I/DEBUG   (22477): 5b512170 ee073a90 eef81bc7 ee611ba0 eef80be7  .:........a.....

I/DEBUG   (22477): 

I/DEBUG   (22477): code around lr:

I/DEBUG   (22477): 5b5125f0 e793210a e2811001 e5851010 e5802008  .!........... ..

I/DEBUG   (22477): 5b512600 e8800050 e783010a eafffff2 ebfffecc  P...............

I/DEBUG   (22477): 5b512610 eaffffcf e59f2028 e3a01008 e59f3024  ....( ......$0..

I/DEBUG   (22477): 5b512620 e3a0e0ec e59fc020 e08f2002 e08f3003  .... .... ...0..

I/DEBUG   (22477): 5b512630 e58de000 e08fc00c e58dc004 eb00083b  ............;...

I/DEBUG   (22477): 

I/DEBUG   (22477): memory map around addr 5b512150:

I/DEBUG   (22477): 5b22f000-5b32e000 

I/DEBUG   (22477): 5b32e000-5b5de000 /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477): 5b5de000-5b5e2000 /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477): 

I/DEBUG   (22477): stack:

I/DEBUG   (22477):     bec3b4a0  019c3488  [heap]

I/DEBUG   (22477):     bec3b4a4  00000124  

I/DEBUG   (22477):     bec3b4a8  574b4574  /data/data/AndroidApplication1.AndroidApplication1/lib/libmonodroid.so

I/DEBUG   (22477):     bec3b4ac  400ad474  

I/DEBUG   (22477):     bec3b4b0  000003af  

I/DEBUG   (22477):     bec3b4b4  40079c25  /system/lib/libc.so

I/DEBUG   (22477):     bec3b4b8  56babc1c  

I/DEBUG   (22477):     bec3b4bc  57853317  /data/dalvik-cache/data@app@AndroidApplication1.AndroidApplication1-1.apk@classes.dex

I/DEBUG   (22477):     bec3b4c0  bec3b54c  [stack]

I/DEBUG   (22477):     bec3b4c4  019c3418  [heap]

I/DEBUG   (22477):     bec3b4c8  67ab5038  

I/DEBUG   (22477):     bec3b4cc  574a4424  /data/data/AndroidApplication1.AndroidApplication1/lib/libmonodroid.so

I/DEBUG   (22477):     bec3b4d0  bec3b554  [stack]

I/DEBUG   (22477):     bec3b4d4  00000001  

I/DEBUG   (22477):     bec3b4d8  df0027ad  

I/DEBUG   (22477):     bec3b4dc  00000000  

I/DEBUG   (22477): #00 bec3b4e0  5b5c13b8  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b4e4  019c3460  [heap]

I/DEBUG   (22477):     bec3b4e8  5b5df180  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b4ec  5b5df180  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b4f0  5b511754  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b4f4  00000000  

I/DEBUG   (22477):     bec3b4f8  000003af  

I/DEBUG   (22477):     bec3b4fc  5b512610  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b500  5b511754  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b504  4007b0ff  /system/lib/libc.so

I/DEBUG   (22477):     bec3b508  5b5e2a6c  

I/DEBUG   (22477):     bec3b50c  00000000  

I/DEBUG   (22477):     bec3b510  bec3b548  [stack]

I/DEBUG   (22477):     bec3b514  5b5df180  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/DEBUG   (22477):     bec3b518  574b4574  /data/data/AndroidApplication1.AndroidApplication1/lib/libmonodroid.so

I/DEBUG   (22477):     bec3b51c  56babc1c  

I/DEBUG   (22477):     bec3b520  000003af  

I/DEBUG   (22477):     bec3b524  5b470c18  /data/data/Mono.Android.DebugRuntime/lib/libmonosgen-2.0.so

I/BootReceiver(  170): Copying /data/tombstones/tombstone_01 to DropBox (SYSTEM_TOMBSTONE)

D/Zygote  (   92): Process 22935 terminated by signal (4)

I/ActivityManager(  170): Process AndroidApplication1.AndroidApplication1 (pid 22935) has died.

W/ActivityManager(  170): Force removing ActivityRecord{4160f230 AndroidApplication1.AndroidApplication1/androidapplication1.Activity1}: app died, no saved state
Comment 2 PJ 2013-06-28 15:22:55 UTC
Kumpera, any thoughts here? It's regression in the 4.7 series based on this comment "So: 4.6.x works. 4.7.x crash in libc."

We're hopefully getting the RC for 4.8 branched soon, so any remaining regression is troublesome. Can you take a look and/or point benjamin towards getting relevant info?
Comment 3 T.J. Purtell 2013-06-28 15:28:30 UTC
I am seeing this (SIGILL immediately on load) with 4.7.9/10/11 on an arm-v7a device (Motorola Atrix 4G) running API level 10.  I also see it in the standard Mono for Android API 10 emulator (arm non v7a).

The app is build with API 16 as the target.

I tried downgrading to 4.6.8 (stable on windows) and building the release version no longer works (LinkAssemblies failure)... so I don't know what to do :(
Comment 4 T.J. Purtell 2013-06-28 15:46:01 UTC
Created attachment 4229 [details]
atrix sigill 4.7.11

This is the logcat information on my android 2.3 device for the SIGILL.
Comment 5 Rodrigo Kumpera 2013-07-11 17:48:13 UTC
Please provide a test case that shows the issue.
Comment 6 T.J. Purtell 2013-07-11 18:57:17 UTC
The test case I was using was a default project created by the IDE of type "Android Application".

I build this application for debug and deploy it on an Android 2.3 API 10 (Motorola Atrix 4G) device and it crashes almost immediately.  I just tested it out once again, and it had the same result.  As I mentioned before it also occurs in the Mono for Android API 10 emulator.

FYI: my version info as reported by Xamarin Studio

Xamarin Studio
Version 4.0.9 (build 12)
Runtime:
	Microsoft .NET 4.0.30319.18047
	GTK 2.24.13
	GTK# (2.12.0.0)

Xamarin.Android
Version: 4.7.11 (Business Edition)
Android SDK: C:\Users\tj\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

Build Information
Release ID: 400090012
f9c5c24e88417feb0319953db6d5fc650d416608
Build date: 2013-06-21 14:03:10Z
Xamarin addins: 898d8afaabb160c025e21656f1490fa149397bff

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 9 Jonathan Peppers 2013-07-29 17:57:42 UTC
We are also seeing this on 4.7.x, but we can't upgrade to 4.8 due to other issues.

Is this fixed in 4.8?
Comment 10 T.J. Purtell 2013-07-29 18:01:34 UTC
From my testing, the default android project works for me on 2.3.

I have seen occasional SIGILL at random times, but the core issue that was blocking me from using 4.7.x at all on 2.3 appears to be fixed.
Comment 11 Rodrigo Kumpera 2013-08-27 11:51:26 UTC
Marking this as dupe of #13957 since no test case has been provided.

*** This bug has been marked as a duplicate of bug 13957 ***

Note You need to log in before you can comment on or make changes to this bug.